Full service web hosting, great prices and support. Starts at $1.99/month!
Results 1 to 2 of 2

Thread: FedEx Upgrading from TLSv1.0/TLSv1.1 to TLSv1.2 - will this affect osCmax?

  1. #1
    Active Member
    FedEx Upgrading from TLSv1.0/TLSv1.1 to TLSv1.2  - will this affect osCmax?


    Join Date
    Sep 2009
    Location
    Vancouver, BC, Canada
    Posts
    482
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    JRR     $ 180.00
    Rep Power
    69


    Default FedEx Upgrading from TLSv1.0/TLSv1.1 to TLSv1.2 - will this affect osCmax?

    Received an email from FedEx recently:
    ----------------------------------------------------
    Date Change for Upgrading from TLSv1.0 to TLSv1.2 – FedEx Web Services Customers
    FedEx is extending the upgrade completion date to March 31, 2020 for transitioning from TLSv1.0 to the more secure version – TLSv1.2.

    Effective January 15, 2020, FedEx will no longer accept TLSv1.1 security protocol for any of our production web services gateway servers. After that date, any communication requests submitted to FedEx using TLSv1.1 protocol will fail.

    Effective March 31, 2020, FedEx will no longer accept TLSv1.0 security protocol for any of our production web services gateway servers. After that date, any communication requests submitted to FedEx using TLSv1.0 protocol will fail. These changes will impact the following production servers:

    https://gateway.fedex.com/web-services

    https://gateway.fedex.com/xml

    https://ws.fedex.com/web-services

    https://ws.fedex.com/xml
    ---------------------------------------------------------
    Is the above something that needs fixing in osCmax?

    John :-#(#

  2. #2
    osCMax Development Team

    FedEx Upgrading from TLSv1.0/TLSv1.1 to TLSv1.2  - will this affect osCmax?

    ridexbuilder's Avatar
    Join Date
    Jul 2008
    Location
    Haggisland
    Posts
    4,134
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    ridexbuilder     $ 15.00
    Rep Power
    96


    Default Re: FedEx Upgrading from TLSv1.0/TLSv1.1 to TLSv1.2 - will this affect osCmax?

    Since The Boss has got rid of the RHS sidebar, it's difficult to see new posts now. (Probably a theme update, or something)
    Generally, the secure handshaking is done at the OS, rather than application level. For example, I set TLS1.2 as an option on my servers about two years ago, subsequently disabling the older versions, oh, months ago now.
    If you can be bothered, search in the module files for "tls" though I'd hope it isn't set to a particular version in PHP!

    Developers resource at bitbucket
    *** *** ***
    oscmax.co.uk / ejsolutions.co.uk
    Hosting plans with installation, configuration, contributions, support and maintenance.
    *** FREE osCmax hosting available ***
    oscmaxtemplates.com

Similar Threads

  1. Upgrading Old OscMax 2.0.3 to 2.0.25
    By giga009 in forum osCmax v2 Installation issues
    Replies: 2
    Last Post: 07-25-2011, 12:15 AM
  2. Upgrading from osCMax 2.0.4 to 2.5.0
    By Marotta1 in forum osCmax v2 Installation issues
    Replies: 5
    Last Post: 12-04-2010, 10:26 AM
  3. Upgrading from Oscmax rc3 to 2.0.4
    By isptalk in forum osCmax v2 Installation issues
    Replies: 6
    Last Post: 12-27-2009, 02:39 PM
  4. Upgrading From osCommerce V2.2 rc2 To osCMax
    By lukeslytalker in forum osCmax v2 Installation issues
    Replies: 4
    Last Post: 02-23-2009, 09:39 AM
  5. Upgrading an old OSC pre MS1 to OscMax v2.
    By cabana in forum osCmax v2 Installation issues
    Replies: 9
    Last Post: 01-25-2006, 09:37 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •