Full service web hosting, great prices and support. Starts at $1.99/month!
Results 1 to 3 of 3

Thread: Store Admin not saving changes?

  1. #1
    Lurker
    Join Date
    Jan 2017
    Posts
    2
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    fiveup     $ 0.00
    Rep Power
    0


    Default Store Admin not saving changes?

    Hi, newbie here, this might be blindingly obvious to some but please play nicely!

    I'm part way through setting up my OsCmax v2.5.4 install. All was going ok but for some reason any changes I make via the admin panel will not save? For example I want to disable the "Printable Catalog", there's a menu entry for this "Printable Catalog-Enable/Disable" but when I choose the value "false" and then "update" I just get a blank page? This happens with every single change I attempt to make throughout the whole admin! Any ideas anybody, is there something I need to enable/disable where my site is hosted via Cpanel? I've heard talk of the .htaccess file but not sure where or how to edit this, if indeed this is the cause or is it some permissions that need altering on some config files somewhere? Thanks in advance!

  2. #2
    Lurker
    Join Date
    Jan 2017
    Posts
    2
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    fiveup     $ 0.00
    Rep Power
    0


    Default Re: Store Admin not saving changes?

    Following on from the above I'm pretty sure it's something to do with my htaccess file. This is my current htaccess file:

    #$Id: .htaccess.new 1857 2012-06-20 01:21:38Z [email protected] $
    #
    # osCmax e-Commerce
    # osCmax - osCommerce Maximized | osCmax shopping cart software
    #
    # Copyright 2000 - 2011 osCmax
    #
    # Released under the GNU General Public License
    #
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter 'Options' to
    # the AllowOverride configuration
    #
    # Example:
    #
    # <Directory "/usr/local/apache/htdocs">
    # AllowOverride Options
    # </Directory>
    #
    # 'All' with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers

    # BOF: Mod RC2A
    #<IfModule mod_setenvif.c>
    # <IfDefine SSL>
    # SetEnvIf User-Agent ".*MSIE.*" \
    # nokeepalive ssl-unclean-shutdown \
    # downgrade-1.0 force-response-1.0
    # </IfDefine>
    #</IfModule>
    # EOF: Mod RC2A

    # If Search Engine Friendly URLs do not work, try enabling the
    # following Apache configuration parameter

    # AcceptPathInfo On

    # Fix certain PHP values
    # (commented out by default to prevent errors occuring on certain
    # servers)

    #<IfModule mod_php4.c>
    # php_value session.use_trans_sid 0
    # php_value register_globals 1
    #</IfModule>
    # BOF: MOD - Ultimate SEO URLs
    ## SEO Url's .htaccess file
    ## If you want to use the Apache Mod-Rewrite method for SEO URL's
    ## NOTE: This requires that you are on an apache web server with mod_rewrite enabled.

    #<IfModule mod_rewrite.c>
    #Options +FollowSymLinks
    #RewriteEngine On

    # Change "catalog" to your catalog directory name:
    #RewriteBase /catalog/
    ## If installed to the base home/root directory, uncomment the below code only:
    #RewriteBase /

    #RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
    #RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_ST RING}
    #RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
    #</ifModule>
    # EOF: MOD - Ultimate SEO URLs

    # BOF: HTTP Error Logging
    # NOTE: if you've installed the catalog in a different directory, change /catalog/ below. Don't leave of the leading /.
    #ErrorDocument 400 /catalog/http_error.php?error_id=400
    #ErrorDocument 401 /catalog/http_error.php?error_id=401
    #ErrorDocument 403 /catalog/http_error.php?error_id=403
    #ErrorDocument 404 /catalog/http_error.php?error_id=404
    #ErrorDocument 405 /catalog/http_error.php?error_id=405
    #ErrorDocument 408 /catalog/http_error.php?error_id=408
    #ErrorDocument 415 /catalog/http_error.php?error_id=415
    #ErrorDocument 500 /catalog/http_error.php?error_id=500
    #ErrorDocument 501 /catalog/http_error.php?error_id=501
    #ErrorDocument 502 /catalog/http_error.php?error_id=502
    #ErrorDocument 503 /catalog/http_error.php?error_id=503
    #ErrorDocument 505 /catalog/http_error.php?error_id=505
    #ErrorDocument 504 /catalog/http_error.php?error_id=504
    # EOF: HTTP Error Logging

    # BOF: Set Expires for common file types
    # ExpiresActive on
    # ExpiresDefault "access plus 24 hours"
    # ExpiresByType image/jpg "access plus 1 months"
    # ExpiresByType image/gif "access plus 1 months"
    # ExpiresByType image/jpeg "access plus 1 months"
    # ExpiresByType image/png "access plus 1 months"
    # ExpiresByType text/css "access plus 1 months"
    # ExpiresByType text/javascript "access plus 1 months"
    # ExpiresByType application/javascript "access plus 1 months"
    # AddType image/x-icon .ico
    # ExpiresByType image/x-icon "access plus 1 months"
    # EOF: Set Expires for common file types

    # BOF: Redirect non-www to www - uncomment all lines below and ensure #RewriteEngine On has been uncommented above
    # RewriteCond %{HTTPS} off
    # RewriteCond %{HTTP_HOST} !^www\.(.*)$ [NC]
    # RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

    # RewriteCond %{HTTPS} on
    # RewriteCond %{HTTP_HOST} !^www\.(.*)$ [NC]
    # RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L]
    # EOF: Redirect non-www to www

    I believe this is the stock correct one? I've certainly not altered anything in here. The domain name that relates to my store is an add on domain via CPanel where I have my main domain and website hosted. Could this main htaccess file over ride settings in my Oscmax htaccess file which resides under my add on domain? My main domain htaccess file is as follows (with domain name replaced by example.com):-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName example.com


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # Password protection
    #ErrorDocument 401
    #AuthType Basic
    #AuthBasicProvider file
    #AuthUserFile /home/example/public_html/passwdfile
    #Require user example

    AuthUserFile "/home/example/.htpasswds/public_html/passwd"

    Any pointers anyone? I'm chasing my tail around in circles trying to resolve this issue and currently nothing will save after I've edited via my admin?? Last resort is probably a fresh install!

  3. #3
    osCMax Development Team

    Store Admin not saving changes?

    ridexbuilder's Avatar
    Join Date
    Jul 2008
    Location
    Haggisland
    Posts
    4,137
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    ridexbuilder     $ 15.00
    Rep Power
    96


    Default Re: Store Admin not saving changes?

    Check out the wiki/search on how to enable error reporting.
    v2.5:installation – osCmax Documentation Wiki
    faq – osCmax Documentation Wiki

    Generally, create a database and user with full access; upload zip file; uncompress the zip; rename the two .htaccess-new to .htaccess, then run the install. Done.


    In the root .htaccess, the Wordpress rewrite section is a possible culprit.

    Note: in future wrap tags around code - find 'em in "Go Advanced" - much easier to read on a forum.
    Note2: your server setup (WHM) may restrict the level of .htaccess files that are read eg. two subdirectories deep.
    Last edited by ridexbuilder; 01-06-2017 at 03:50 PM. Reason: didn't want to give a bum steer

    Developers resource at bitbucket
    *** *** ***
    oscmax.co.uk / ejsolutions.co.uk
    Hosting plans with installation, configuration, contributions, support and maintenance.
    *** FREE osCmax hosting available ***
    oscmaxtemplates.com

Similar Threads

  1. Quantum Gateway not saving order details after checkout
    By avs in forum osCommerce 2.2 Modification Help
    Replies: 3
    Last Post: 07-21-2010, 12:13 PM
  2. discount coupons admin page only saving partial information
    By tunnel7 in forum osCMax v2 Features Discussion
    Replies: 4
    Last Post: 01-03-2010, 05:14 PM
  3. Product options aren't saving using categories.php
    By smartwork in forum osCMax v2 Features Discussion
    Replies: 1
    Last Post: 11-09-2009, 09:15 AM
  4. Product Description not Saving
    By toddw in forum osCmax v2 Installation issues
    Replies: 1
    Last Post: 01-29-2006, 07:58 PM
  5. some orders saving all details as blank
    By techmatters in forum osCmax v1.7 Discussion
    Replies: 0
    Last Post: 07-14-2005, 09:47 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •