Full service web hosting, great prices and support. Starts at $1.99/month!
Results 1 to 10 of 10

Thread: Can not run oscmax install script on php5 - here is the fix

  1. #1
    rabbit79
    Guest


    Default Can not run oscmax install script on php5 - here is the fix

    I was trying to run the install script but when i try to go to step 2 (after customize page) the page stays the same even when I press "Continue" button. No error's messages, nothing. I'm running apache 2.2.4+PHP 5+ MySQL5.

    Thanks.

  2. #2
    jpf
    Guest


    Default Re: Can not run install script

    Had the same problem here
    This is a php 5 problem I think.

    See:
    Installing PHP5 reg_global=off, long_arrays=off
    PHP5 and MySQL 4.1 (Don't Dispare)

    Try editing php.ini and change:
    register_long_arrays = Off
    To:
    register_long_arrays = On

    That seems to do the trick for me.

  3. #3
    rabbit79
    Guest


    Default Re: Can not run install script

    Work's fine now.

    Thank's

  4. #4
    egonzalez
    Guest


    Wink Re: Can not run oscmax install script on php5 - here is the fix

    Works great, thank you for the fix!

  5. #5
    jschafer52
    Guest


    Default Re: Can not run oscmax install script on php5 - here is the fix

    where do i get to the php.ini?

    sorry,
    JIM

  6. #6
    jpf
    Guest


    Default Re: Can not run oscmax install script on php5 - here is the fix

    Depends....(greatly) on the hosting environment and what the hosting company allows you access to.

    1) if it is your server - then search for php.ini

    2) try adding a overide file

    In an editor create a file called (or modify the existing one):
    .htaccess
    (must have the period before - and nothing before the period)
    add to that file the lines:
    php_value register_globals 1
    php_value register_long_arrays 1

    Make sure your FTP software displays system files as well.

    Upload that file to your root of your website.

    3) Ask your hosting company where it is or to do it for you.

    4) If they refuse - Move Hosting companies....

  7. #7
    Nimitz_1061
    Guest


    Default Re: Can not run oscmax install script on php5 - here is the fix

    Note that you may have to upload the php.ini file to your admin and to the install directory as well in order to have the changes work in all locations..

    (php.ini files should NOT affect the server recursively, to the best of my knowledge..)

    David

  8. #8
    pr3da70r
    Guest


    Arrow Re: Can not run oscmax install script on php5 - here is the fix

    I'm having the same problem. Here's what my php configuration shows..

    Code:
    Directive	Local Value	Master Value
    allow_call_time_pass_reference	On	On
    allow_url_fopen	On	On
    allow_url_include	On	On
    always_populate_raw_post_data	Off	Off
    arg_separator.input	&	&
    arg_separator.output	&	&
    asp_tags	Off	Off
    auto_append_file	no value	no value
    auto_globals_jit	On	On
    auto_prepend_file	no value	no value
    browscap	no value	no value
    default_charset	no value	no value
    default_mimetype	text/html	text/html
    define_syslog_variables	Off	Off
    disable_classes	no value	no value
    disable_functions	no value	no value
    display_errors	On	On
    display_startup_errors	Off	Off
    doc_root	no value	no value
    docref_ext	no value	no value
    docref_root	no value	no value
    enable_dl	On	On
    error_append_string	no value	no value
    error_log	no value	no value
    error_prepend_string	no value	no value
    error_reporting	no value	no value
    expose_php	Off	Off
    extension_dir	./	./
    file_uploads	On	On
    highlight.bg	#FFFFFF	#FFFFFF
    highlight.comment	#FF8000	#FF8000
    highlight.default	#0000BB	#0000BB
    highlight.html	#000000	#000000
    highlight.keyword	#007700	#007700
    highlight.string	#DD0000	#DD0000
    html_errors	On	On
    ignore_repeated_errors	Off	Off
    ignore_repeated_source	Off	Off
    ignore_user_abort	Off	Off
    implicit_flush	Off	Off
    include_path	.:/usr/local/php5/lib/php	.:/usr/local/php5/lib/php
    log_errors	Off	Off
    log_errors_max_len	1024	1024
    magic_quotes_gpc	On	On
    magic_quotes_runtime	Off	Off
    magic_quotes_sybase	Off	Off
    mail.force_extra_parameters	no value	no value
    max_execution_time	30	30
    max_input_nesting_level	64	64
    max_input_time	60	60
    memory_limit	32M	32M
    open_basedir	no value	no value
    output_buffering	0	0
    output_handler	no value	no value
    post_max_size	8M	8M
    precision	12	12
    realpath_cache_size	16K	16K
    realpath_cache_ttl	120	120
    register_argc_argv	On	On
    register_globals	On	On
    register_long_arrays	On	On
    report_memleaks	On	On
    report_zend_debug	On	On
    safe_mode	Off	Off
    safe_mode_exec_dir	/usr/local/php/bin	/usr/local/php/bin
    safe_mode_gid	Off	Off
    safe_mode_include_dir	no value	no value
    sendmail_from	no value	no value
    sendmail_path	/usr/sbin/sendmail -t -i 	/usr/sbin/sendmail -t -i 
    serialize_precision	100	100
    short_open_tag	On	On
    SMTP	relay-hosting.secureserver.net	relay-hosting.secureserver.net
    smtp_port	25	25
    sql.safe_mode	Off	Off
    track_errors	Off	Off
    unserialize_callback_func	no value	no value
    upload_max_filesize	2M	2M
    upload_tmp_dir	/tmp	/tmp
    user_dir	no value	no value
    variables_order	EGPCS	EGPCS
    xmlrpc_error_number	0	0
    xmlrpc_errors	Off	Off
    y2k_compliance	On	On
    zend.ze1_compatibility_mode	Off	Off
    PHP Version 5.2.5
    MySQL version 4.1
    OS: Linux
    Server API: CGI/FastCGI
    Apache: 1.3.33 (I think)

    I also tried to upload php.ini and php5.ini to the admin and install directories to make sure that register_globals and register_long_arrays is enabled.

    Any tips on what I might be missing? Really want to get this installed..

    EDIT: Is there a way to manually install the script without going through install.php? And just to re-iterate, my script keeps looping back to step 2 and "freezing" there, refusing to go forward until I cancel and start over again, where it goes to step 2 or 3 before looping back to step 2 and freezing there each time. I used phpmyadmin to import the sql but have no idea what else I need to configure. Perhaps configure.php in the admin/includes and the /includes/ directory?

    Thanks for the help in advance
    Last edited by pr3da70r; 07-26-2008 at 09:15 AM. Reason: Adding a question, please see the EDIT: section.

  9. #9
    sunil
    Guest


    Default Re: Can not run oscmax install script on php5 - here is the fix

    Hello,
    I am also facing same problem while Instalation in step 2,
    I am beginer php programer,
    but since begin I am working on osCommercs, I have comlpited two project with oscommercs very well with many criticle changes on my level.
    Now I want to work on oscmax2, but I am facing some probleme in instalation step 2,
    whene I click on countine Nothing happpend any process, Why? I dont Know.
    Can anyone help me for that?

    My Server Configuration

    Apache Version : 2.2.11 PHP Version : 5.2.8 MySQL Version : 5.1.30 Tanks you.
    Last edited by sunil; 02-18-2009 at 05:45 AM. Reason: have to add important things.

  10. #10
    jpf
    Guest


    Default Re: Can not run oscmax install script on php5 - here is the fix

    osCMax RC3 and older is really not php5 compatable. However SVN (RC4 beta) is php5 compatable.

    I would suggest you checkout the SVN .

Similar Threads

  1. Unable to install on Windows with PHP5
    By mottolini in forum osCommerce 2.2 Installation Help
    Replies: 1
    Last Post: 10-21-2005, 06:37 AM
  2. Can't install Oscommerce - only one script in root directory
    By dalglish in forum osCommerce 2.2 Installation Help
    Replies: 1
    Last Post: 01-16-2005, 01:09 PM
  3. install script NOT THERE!!
    By ReginaStelling in forum osCMax v1.7 Installation
    Replies: 4
    Last Post: 06-29-2004, 07:59 AM
  4. Install script fails to log into mysql server
    By bjrafferty in forum osCMax v1.7 Installation
    Replies: 7
    Last Post: 06-23-2004, 07:37 PM
  5. No Install Script
    By ramonjaime in forum osCommerce 2.2 Installation Help
    Replies: 4
    Last Post: 11-13-2002, 05:02 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •