Results 1 to 3 of 3

Thread: Products default to content type virtual or 'downloadable'

  1. #1
    cameroti
    Guest


    Default Products default to content type virtual or 'downloadable'

    Hi all,

    Have noticed that products loaded following a clean install of RC2 automatically have assigned the content_type virtual. That is they are treated as if downloadable.

    This occurs if you do a clean install, don't change any configuration variables, and start loading products.

    Is there some configuration variable that changes this default?

    Any thoughts appreciated.

    Cheers
    Tim

  2. #2
    osCMax Developer


    Products default to content type virtual or 'downloadable'

    michael_s's Avatar
    Join Date
    Jul 2002
    Location
    Phoenix, AZ
    Posts
    23,012
    Total Contributions For

    michael_s     $ 10.00
    Rep Power
    594


    Default RE: Products default to content type virtual or

    Did you set the weight of your products to a non-zero value? Undefined of zero weight is reserved for virtual products.
    Michael Sasek

    osCmax 2.5.4 is now available via auto-installation using Softaculous!

    Stay Up To Date with everything osCMax:
    osCmax on Twitter - Up to the minute info as it happens. Know it first.

    osCmax Documentation

  3. #3
    cameroti
    Guest


    Default

    Thanks Michael. Well I sort of set the weight..... I knew I had to, so I did it via EasyPopulate. This is how I fell into the trap (for other unwary travellers.....). We have many products so I loaded this shop using EasyPopulate. I loaded one dummy product and then exported via EasyPopulate to get the right table headings, I then filled in all of our products.... AND ... copied down the EORER(sp?) line at the end.... BUT... when I did so I picked up a few other columns at the end including content_type, so the dummy product was of content_type Download:Windows - English, SO .... all my products ended up with a weight and downloadable status. Needless to say they were treated as virtual and my troubles began!

    Hopes this help someone else avoid this pitfall, or find the answer quicker than I did.

    Cheers
    Tim

Similar Threads

  1. Downloadable products not downloading
    By iluminada in forum osCmax v2 Installation issues
    Replies: 3
    Last Post: 11-29-2005, 07:49 PM
  2. AutoGenerating Authorization for Downloadable products ?
    By zonzo_1 in forum osCMax v1.7 General Mods Discussion
    Replies: 0
    Last Post: 11-09-2005, 08:33 AM
  3. Virtual Product Still Charges Handling
    By kenlyle in forum osCmax v1.7 Discussion
    Replies: 2
    Last Post: 11-08-2005, 05:24 PM
  4. Changing default TAX class when adding new products
    By fuzzyphil in forum osCMax v1.7 General Mods Discussion
    Replies: 0
    Last Post: 07-28-2005, 10:42 PM
  5. DOWNLOADABLE PRODUCTS - EXPIRY DAYS BUG - Probably!!!
    By norb in forum osCmax v1.7 Discussion
    Replies: 6
    Last Post: 03-29-2004, 10:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •