Full service web hosting, great prices and support. Starts at $1.99/month!
Results 1 to 4 of 4

Thread: help needed with issues after Godaddy moved my files to new server

  1. #1
    Member
    help needed with issues after Godaddy moved my files to new server


    Join Date
    May 2017
    Posts
    78
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    Markcm     $ 0.00
    Rep Power
    4


    Default help needed with issues after Godaddy moved my files to new server

    Hi Folks,

    Godaddy recently moved my files to a new server and afterwards:

    -my site's home page has a header warning stating "downloadable content missing" or some thing to that effect

    -admin panel warning about downloadable content, I disabled downloading which cleared the warning and I don't use downloadable content but still...

    -admin panel warning that configure file can be written to. I checked and it looks like all my file permissions had changed after the godaddy migration so I changed config to 444 which cleared the error message but I'm not sure if this is the best action. is there a list of what file properties I can reference?

    -admin panel for backups reports "Backup directory does not exist. Please set this in configure.php". This directory still exists and my prior backups are still there. I checked my configure file which appears to still point to the correct location as well.

    -admin panel Orders page will not load anymore

    -admin panel catalog (AKA: categories) will not load anymore

    I've looked in the directories and files for anything obvious but nothing stands out to me that would cause these. Does anyone have any suggestions for these issues? my site is a fairly vanilla 2.5.2 installation.

    Thanks.

  2. #2
    osCMax Developer


    help needed with issues after Godaddy moved my files to new server

    michael_s's Avatar
    Join Date
    Jul 2002
    Location
    Phoenix, AZ
    Posts
    23,013
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    michael_s     $ 10.00
    Rep Power
    594


    Default Re: help needed with issues after Godaddy moved my files to new server

    The documentation for permissions:
    v2.5:installing_via_ftp – osCmax Documentation Wiki

    Most likely your issues are stemming from a change in php version. Find out the current php version on the server and compare that to the old server's php version. If it's php 5.6 or 7, that is the cause of your issues (most likely).

    For the pages that won't load, enable error reporting to the screen so you can see what errors PHP is generating. Post them here so we can take a look.
    Michael Sasek

    osCmax 2.5.4 is now available via auto-installation using Softaculous!

    Stay Up To Date with everything osCMax:
    osCmax on Twitter - Up to the minute info as it happens. Know it first.

    osCmax Documentation

  3. #3
    Member
    help needed with issues after Godaddy moved my files to new server


    Join Date
    May 2017
    Posts
    78
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    Markcm     $ 0.00
    Rep Power
    4


    Default Re: help needed with issues after Godaddy moved my files to new server

    Thanks Michael

    From my admin panel Tools --> Server info, it reports: PHP Version 5.2.17 (Zend: 2.2.0)

    I enabled error reporting in both my store side and admin side, everything seems to load in the store side and the only pages that I have found not loading in admin is catalog, orders, and it when I try to access my backups it reports "Error: Backup directory does not exist. Please set this in configure.php." yet the directory is there and the backup files are still in it. I can load WOL, products, Home, all the configuration pages, reports...

    I don't receive any error reports on any pages. When I click to load these pages the response is a fully blank screen. If I use google to inspect the source there is nothing generated at all, it just reads
    <html>
    #shadow-root (open)
    <head></head>
    <body></body> == $0
    </html>
    I also checked the Admin Home page HTTP Error Log but there are no entries.

    Any other ideas why these pages wont load? I've tried on multiple browsers from multiple machines and cleared the cache.

  4. #4
    Member
    help needed with issues after Godaddy moved my files to new server


    Join Date
    May 2017
    Posts
    78
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    Markcm     $ 0.00
    Rep Power
    4


    Default Re: help needed with issues after Godaddy moved my files to new server

    I found the cause to why my catalog and orders pages would no longer load in admin after Godaddy moved my files to a new server.

    After Godaddy moved my domain to a new server I had to update my configure.php files for all of the FS defines such as:

    DIR_FS_CATALOG
    DIR_FS_HOST_ROOT
    DIR_FS_DOCUMENT_ROOT
    DIR_FS_ADMIN

    I used the admin panel --> TOOLS --> Server Info to find the updated path for these FS Defines.

    PS- my Godaddy PHP version is 5.2 and when I enabled error reporting, there were no errors. When I tried to load my catalog or orders it would just generate a blank page, inspecting source code revealed no code.
    Last edited by Markcm; 06-06-2017 at 02:38 PM.

Similar Threads

  1. Moving a site to Godaddy server
    By DanDan in forum Installation/Setup
    Replies: 3
    Last Post: 11-11-2013, 06:36 AM
  2. Lost all files just have the database (Reinstalation needed)
    By chowhan in forum osCmax v2 Installation issues
    Replies: 5
    Last Post: 06-06-2009, 03:00 AM
  3. moved oscmax to new server, still LIVE...issues
    By abacususer in forum osCMax v1.7 Installation
    Replies: 3
    Last Post: 02-08-2008, 08:52 PM
  4. files to edit don't exist on our server - there's more
    By bbw in forum osCmax v2 Customization/Mods
    Replies: 9
    Last Post: 02-17-2006, 07:33 AM
  5. moved to new server and experiencing set-up errors.
    By innovations in forum osCMax v1.7 Installation
    Replies: 2
    Last Post: 11-28-2003, 10:40 AM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •