Full service web hosting, great prices and support. Starts at $1.99/month!
Page 2 of 5 First 1234 ... LastLast
Results 11 to 20 of 43

Thread: PHP 5.4.4 and osCmax 2.5.3 issue

  1. #11
    idahowebguy
    Guest


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    I did this fix to the language file and at least the pages are not blank, but if you try to buy something in the store it leaves the pricing blank. Any Ideas?

  2. #12
    osCMax Development Team

    PHP 5.4.4  and osCmax 2.5.3 issue

    pgmarshall's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    3,517
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    pgmarshall     $ 35.00
    Rep Power
    77


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Do you mean that all the prices displayed are blank? Or that they don't go into the cart?

    Also are you using localhost to develop or are you on an online server?

    Regards.
    pgmarshall
    _______________________________

  3. #13
    idahowebguy
    Guest


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    I have 4 website that were all live, the host provider upgraded to PHP 5.4 and first the blank screen was an issue, so I hard coded the language as it was suggested, but then I noticed when I tried to purchase an item in the store it did not carry the price of the item to the checkout and told me there was nothing in my cart. After trying to get some help, I talked the provider to moving all the sites to a php 5.3 server and they all work now, but I only have until the 9th of September to find a fix as that server will be then upgraded also. I saved one site on the upgraded server and can give it as an example if you like.

  4. #14
    idahowebguy
    Guest


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    I had this same problem and hard coding the language fixed the blank screen problem but I also have a similar problem on pricing after I select an item and go to check out the dollar amount disappears. I can bring it back by adding "&currency=usd" can you tell me if there is a place to hard code this also? Idahowebguy

  5. #15
    jmdesign
    Guest


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Was there ever a fix for this as all my sites have experienced the same problem this morning. Michael's fix gets rid of the white screen however no currencies are being applied but they show when I type in www.websitename.com/index.php?&currency=gbp

    Thanks,

    James

  6. #16
    jmdesign
    Guest


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Okay ignore this, I managed to get around it by getting my host to reconfigure Apache.

  7. #17
    Member
    Join Date
    May 2009
    Posts
    71
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    giga009     $ 0.00
    Rep Power
    11


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Hi... we have just had the server upgraded to php 5.3 and are using v2.5.3 OSCmax. We have fixed the blank screen with the fix Zips above (a BIG THANK YOU ) however we too have no prices at all......throughout the site... just 0 showing.....our currency is AUD and no prices show in product/ nor checkout. I am trying to find a solution with this but to no avail. I have tried to revert back to USD via admin but this too did not change anything.
    Has anyone fixed this issue ?

    Any assistance would be greatly appreciated.
    Giga

  8. #18
    Member
    Join Date
    May 2009
    Posts
    71
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    giga009     $ 0.00
    Rep Power
    11


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Another Question

    Would Hardcoding the AUD into the code help to bring back the prices? Could you assist in telling me where/which file this now goes into? I have looked in the core.php file but can't see where I could hardcode andything like &currency=usd to &currency=AUD

    Cheers
    Tracy

  9. #19
    osCMax Development Team

    PHP 5.4.4  and osCmax 2.5.3 issue

    pgmarshall's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    3,517
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    pgmarshall     $ 35.00
    Rep Power
    77


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Do you have a link to demonstrate the issue?

    catalog/includes/languages/english/locale.php is where the language and currency defaults are set.

    Regards,
    pgmarshall
    _______________________________

  10. #20
    Member
    Join Date
    May 2009
    Posts
    71
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    giga009     $ 0.00
    Rep Power
    11


    Default Re: PHP 5.4.4 and osCmax 2.5.3 issue

    Thanks pgmarshall for your prompt response and information regarding hard coding. In regards to a link can I pm you the link as it is a clients site and I would rather not send their site info here I hope you understand

    Cheers
    giga

Page 2 of 5 First 1234 ... LastLast

Similar Threads

  1. oscmax on WAMP issue
    By 2001kx in forum Installation/Setup
    Replies: 13
    Last Post: 04-30-2013, 02:54 PM
  2. [osCmax v2.5x] osCmax v2.5 Beta 2 - Set up Issue
    By ckaya2000 in forum osCmax v2 Installation issues
    Replies: 8
    Last Post: 01-07-2011, 11:02 PM
  3. Tax issue on osCMax
    By edimv in forum osCommerce 2.2 Installation Help
    Replies: 1
    Last Post: 02-04-2009, 10:53 PM
  4. Tax issue on osCMax
    By edimv in forum Introduce yourself!
    Replies: 1
    Last Post: 02-04-2009, 10:53 PM
  5. Dynamic mopics issue with Internet Explorer - osCMax
    By GroeneKikker in forum osCmax v2 Customization/Mods
    Replies: 3
    Last Post: 10-01-2008, 06:51 AM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •