PDA

View Full Version : Shopping cart empties after login.



bsa
08-24-2003, 07:23 PM
Hello,

I don't know if this is AABox specific. My webserver has an httpdocs directory and a secure httpsdocs directory. I have simply copied the catalog directory into both. If I fill up my cart then login the shopping cart is empty. I set STORE_SESSIONS to 'mysql', if I set STORE_SESSIONS to '' then it just gets really weird. If I try to symlink the httpsdocs/catalog to httpdocs/catalog I get a PHP open_basedir() error. Does anybody know how to make PHP follow symlinks? Will that even fix my problem? My "Visitor Cart" is not merging with the "Member Cart". The HTTP_COOKIE_DOMAIN and HTTPS_COOKIE_DOMAIN are exactly the same, as are the COOKIE_PATHs.

Thanks,
Brad

bsa
08-24-2003, 07:29 PM
Here is my server info in case it is a version problem.

Server OS: Linux 2.4.18-17.7.x Database: MySQL 3.23.49
Server Date: 08/24/2003 23:27:58 Datebase Date: 08/24/2003 23:27:58
Server Up Time: 11:27pm up 178 days, 46 min, 1 user, load average: 0.00, 0.00, 0.00

HTTP Server: Apache/1.3.23 (Unix) (Red-Hat/Linux) FrontPage/5.0.2.2623 mod_ssl/2.8.7 OpenSSL/0.9.6b DAV/1.0.3 PHP/4.1.2 mod_perl/1.26
PHP Version: 4.1.2 (Zend: 1.1.1)

bsa
08-24-2003, 07:55 PM
I've actually symlinked my /httpsdocs to /httpdocs and I am still having the same problem. I'm running Plesk 5.0 on my server and I got that tip from the Plesk forums.

Thanks,
Brad

michael_s
08-24-2003, 11:18 PM
First, try turning "Force Cookies" to False in the admin and see if that clears up the problem

If it does, you have a cookie path issue. If not, the issue is probably with the path settings in configure.php

This suggestion will not solve your trouble, but at least get closer to a cause.

bsa
08-25-2003, 07:02 PM
Solved it, thanks for directing me to the sessions portion of the configuration. I had the following set to true, which will of course cause a shopping cart to empty:

Recreate Session
Recreate the session to generate a new session ID when the customer logs on or creates an account (PHP >=4.1 needed).

The "Force Cookies" didn't do it.

Thanks again,
Brad