PDA

View Full Version : Logo and Banner not recognized



disciple
08-15-2003, 05:25 AM
Hi,

I have a strange problem. I am using the aabox download (very nice, thanks). I have replaced in header.php the oscommerce.gif with my own logo.gif but when viewing the file the oscommerce.gif is still the one that shows. Yet, if I rename my logo.gif to oscommerce.gif then it works. I realize that this is the simple fix but I want to know why something is not working when it should.

Secondly, I deleted out the code in footer.php for the osc banner and the same thing it still shows!!

How can this happen. I am so confused! :?

Thanks in advance for your help.

Here is the code I am using for both of the above problems.

HEADER.PHP

<td valign="middle"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'dobie.gif', 'DobieDay') . '</a>'; ?></td>

FOOTER.PHP

<?php
/*
$Id: footer.php,v 1.26 2003/02/10 22:30:54 hpdl Exp $

osCommerce, Open Source E-Commerce Solutions
http://www.oscommerce.com

Copyright (c) 2003 osCommerce

Released under the GNU General Public License
*/

require(DIR_WS_INCLUDES . 'counter.php');
?>
<table border="0" width="100%" cellspacing="0" cellpadding="1">
<tr class="footer">
<td class="footer">&&<?php echo strftime(DATE_FORMAT_LONG); ?>&&</td>
<td align="right" class="footer">&&<?php echo $counter_now . ' ' . FOOTER_TEXT_REQUESTS_SINCE . ' ' . $counter_startdate_formatted; ?>&&</td>
</tr>
</table>
<br>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
<tr>
<td align="center" class="smallText">
<?php
/*
The following copyright announcement can only be
appropriately modified or removed if the layout of
the site theme has been modified to distinguish
itself from the default osCommerce-copyrighted
theme.

For more information please read the following
Frequently Asked Questions entry on the osCommerce
support site:

http://www.oscommerce.com/community.php/faq,26/q,50

Please leave this comment intact together with the
following copyright announcement.
*/

echo FOOTER_TEXT_BODY
?>

michael_s
08-15-2003, 08:14 AM
This happens because those files are no longer used to control the look of osC.

You need the edit the files in the /catalog/templates directory:

main_page.tpl.php

Almost EVERY cosmetic change is handled by the files in this dir and the sub-directories.

*** I am moving this post to the MS2-MAX forum ***

disciple
08-15-2003, 08:46 AM
I just figured this out.

I was coming back to tell everyone to ignore my post.

Thanks for the answer anyway. It may help someone else down the road.

Rick

proton318
11-13-2003, 09:54 AM
Am I am missing something here?? I have used the mainpage template before to replace the logo on my page ... just as mentioned above ... but now I have a new company logo ... when I change the mainpage template to show the new GIF file, it does not recognize it ... it still looks for and displays the old file.

Anyone know what I might be missing?

Thanks!! :oops:

proton318
11-13-2003, 10:12 AM
Forget that last post, I am a moron!! :roll:

I was editing the wrong code ... I've been staring at PHP for way too long!!

Lynoure
11-18-2003, 02:25 PM
I have edited the mainpage template. However, if I click on Gift Voucher FAQ, the logo and icons on the header of the page revert to the unedited ones. I guess Gift Voucher FAQ doesn't for some reason use mainpage template. Do I need to make the changes for the logo & icons in some non-template file as well?