PDA

View Full Version : Errors using USPS shipping module



gmulford
01-28-2007, 10:43 PM
Hi, I'm using a fresh install of OSCMAX 2.0 and have an account setup at the USPS website, yet when i enable and enter in all my info into the USPS shipping module I get an error during checkout:

----------
This is currently the only shipping method available to use on this order.

United States Postal Service
An error occured with the USPS shipping calculations.
If you prefer to use USPS as your shipping method, please contact the store owner.

----------
here's my config:

Enable USPS Shipping
True

Enter the USPS User ID
myuserid (My real ID not shown here ;-) )

Enter the USPS Password
*******

Which server to use
production

Handling Fee
0

Tax Class
Taxable Item

Shipping Zone
--none--

Sort Order
0

USPS Options
--none--

Domestic Shipping Methods
Priority

Int'l Shipping Methods
Express

US/Canada to $50
1.30

US/Canada $50-100
2.20

US/Canada per $100
1.00

International to $50
1.85

International $50-100
2.60

International per $100
1.00

Insure Packages
True

Insure Tax
True


Any idears?

michael_s
01-29-2007, 07:34 AM
Does your server meet the requirements of the mod and have curl compiled into php?

Did you register, configure and activate your USPS account through USPS?

gmulford
01-29-2007, 06:07 PM
Does your server meet the requirements of the mod and have curl compiled into php?

Did you register, configure and activate your USPS account through USPS?

Yes and Yes.

-G

michael_s
01-29-2007, 07:02 PM
I bet USPS has not really activated your account on the production server... This happens all the time. You need to get someone on the phone to verify this. It is the post office you are dealing with you know. ;)

I have had people swear up and down that they are activated, and when I call USPS, I find that they actually have not been, even though they were told otherwise.

USPS module works fine as long as they have you turned on. If you are not getting any other error messages, that is the most likely culprit.

gmulford
01-30-2007, 12:08 PM
I bet USPS has not really activated your account on the production server... This happens all the time. You need to get someone on the phone to verify this. It is the post office you are dealing with you know. ;)

I have had people swear up and down that they are activated, and when I call USPS, I find that they actually have not been, even though they were told otherwise.

USPS module works fine as long as they have you turned on. If you are not getting any other error messages, that is the most likely culprit.
Thanks. I'll check it out with USPS and get back to you.

-G

gmulford
02-02-2007, 10:32 AM
Okay, I called USPS and they activated my "Webtools" account and gave me the email below. It gives me a userid but no password (the OSCmax module asks for a USPS User ID and Password). Also asking me for a API name? I dunno if this is allready in the module or not (probably is). This is all very confusing.

I tried every combination i could think of and nothing works. Using my login into for the website, user id they provided me below etc. Still getting same error. The USPS people said that I have to "test" the server out first and confirm that it works before putting me into "production" mode. see the email below:

------------
Thank you for registering for the U. S. Postal Service's Web Tools Application Program Interfaces (APIs). We are providing you with a User ID that serves multiple purposes, as explained below.

Your Web Tools User ID is: XXXXXXXXXXX (I removed the ID here)


Your Web Tools User ID, shown above, is required to test and integrate USPS Web Tools APIs. With this ID, you may begin sending calls to the test server. Depending on the API, the address to the test server is either http://testing.shippingapis.com/ShippingAPITest.dll or https://secure.shippingapis.com/ShippingAPITest.dll. Use this information in combination with your User ID and your XML string to send a request to the USPS servers. For more details, refer to the programming guides (located at USPS - USPS Web Tools (http://www.usps.com/webtools)) for the specific API you are integrating.

A sample test request would look like: "http://testing.shippingapis.com/ShippingAPITest.dll?API=[API_Name]&XML=[XML_String_containing_User_ID]"

When you have completed your testing, email the USPS Internet Customer Care Center (ICCC). They will switch your profile to allow you access to the production server and will provide you with the production URLs.

The ICCC is staffed from 7:00AM to 11:00PM Eastern Time.

E-mail: [email protected]
Telephone: 1-800-344-7779

The latest versions of the technical documentation, including the Administrative Guide, are available from USPS.com at USPS - USPS Web Tools (http://www.usps.com/webtools). This documentation provides the information you will need to utilize our APIs. It is available in both PDF and HTML formats. In order to open and view in PDF you must have Adobe Reader installed on your system. You may download this software, at no cost, from Adobe - Adobe Reader Download - All versions (http://www.adobe.com/reader).


IMPORTANT NOTICE REGARDING USER ID


The Web Tools User ID provided is for you and your company to use when requesting data via the Internet from the U.S. Postal Service API servers. This unique User ID cannot be shared with others outside your organization, nor is it to be packaged and distributed or sold to other individuals, businesses or e-commerce web site entities. As per the Terms and Conditions of Use Agreement you agreed to during the Web Tools registration process, you are responsible to maintain the confidentiality of your User ID as specified. You may not package any APIs with your User ID for resale or distribution to others. The U.S. Postal Service does not prohibit the reuse and/or distribution of the API documentation (User's Guide) with sample code in order to generate awareness, encourage use or provide ease-of-use to customers or affiliates.

Warning - If the U.S. Postal Service discovers use of the same User ID from more than one web site, all users will be subject to loss of access to the USPS production server and/or termination of the licenses granted under the Terms and Conditions of Use. For more information regarding the USPS Web Tools User ID policy, or for questions regarding distribution of documentation, send email to [email protected]

Thank you for helping the U.S. Postal Service provide new services to our shipping customers.

Sincerely,

The Internet Shipping Solutions Team

Mushroom
02-10-2007, 08:34 AM
For anyone who has this problem. The user ID and password are the same. I have my user ID entered in both the ID and the password blocks of my module.