PDA

View Full Version : Email not sent after new customer account is created.



Dumb_Question
12-11-2005, 09:55 PM
A customer called today. She said she didnt receive any emails after she placed an order.

I created a new test account just to verify. I noticed the same problem. Emails worked fine before this.

Can someone help please.

Thank you.

macfionn
12-12-2005, 12:49 PM
Start troubleshooting by attempting to send yourself an email in the admin screen. This is just to verify that the code can still access the server. If it can, then it sounds like something was alterered (since you stated it once worked before.) Have you been working in the admin panel or adding any specific new mods?

If you cannot recieve any mail from the admin functions either, you may want to verify in admin panel that your 'sendmail' or 'SMTP' wasnt inadvertantly switched one for the other. Also if any firewall changes had been made that may be blocking outgoing mail (especially if self hosted.)

If you had made NO changes to the code or to the admin screen and you are NOT self hosted, then give a quick call your site host and ask them to quickly check status of your email server.

Dumb_Question
12-13-2005, 07:12 AM
Admin does send emails. I believe customers do get emails after they place an order. It is just the initial email ( after the account is created) and the additional copy of the order ( to me) that are not being sent.

As far as changes go, I had someone work on the site . he did install some contributions but then disappared leaving the site with issues like these.

sendmail config is correct.

Will appreciate your help.

bkpie
12-14-2005, 11:01 AM
This was also brought up in the features discussion part of the forum today. I also have been having the same issue. It should probably be addressed and made sticky since so many are asking about this now. I have checked everything based on the posts and it seems to be correct

michael_s
12-14-2005, 11:22 AM
I Cannot reproduce the problem on our dev shop, and I fixed it on another's site, so unless someone posts more specifics about their system and setup, there is nothing further I can do to help...

Is this RC2? Patched or not? Any other mods or is it stock? OS/PHP/MySQL versions? This should be automatic on any post like this...

Christy
12-14-2005, 07:57 PM
I have a similar problem and I have RC2 ...unpatched with the latest security patch.
I have had QBI and Open CRM installed

PHP Version: 4.3.11 (Zend: 1.3.0)
MySQL 4.0.16
Host is ipowerweb

Christy
12-16-2005, 04:53 PM
Today, I installed the latest security/update patch but the problem continues.

Anyone had any luck?

Chrity

nikolajpop
12-16-2005, 05:37 PM
I have the same problem with email.php file from includes/classes/email.php.

These are info of site and versions:

OSCmAX 2.0 RC2
MySQL 4.0.16
4.3.11 (Zend: 1.3.0)
Apache/1.3.33 (Unix) mod_log_bytes/0.3 FrontPage/5.0.2.2635 PHP/4.3.11 mod_ssl/2.8.22 OpenSSL/0.9.7d


The problem I'm getting is a problem with constant(CHARTSET) written after a new customer enters personal details for new account.

Error are:


Warning: constant(): Couldn't find constant CHARSET in /home/ativasat/public_html/includes/classes/email.php on line 61

Warning: constant(): Couldn't find constant CHARSET in /home/ativasat/public_html/includes/classes/email.php on line 62

Warning: constant(): Couldn't find constant CHARSET in /home/ativasat/public_html/includes/classes/email.php on line 61

Warning: constant(): Couldn't find constant CHARSET in /home/ativasat/public_html/includes/classes/email.php on line 62

Warning: Cannot modify header information - headers already sent by (output started at /home/ativasat/public_html/includes/classes/email.php:61) in /home/ativasat/public_html/includes/functions/general.php on line 35

Any help apreciated.