PDA

View Full Version : OSCMax v2 - Stuck on New Installation Database Import



Geno11x11
12-01-2005, 08:41 PM
OSCMax v2 with the latest patch
PHP5
MySQL4
Apache 2 on Windows XP Pro

I have created a user/password and a database in MySQL called OscMax, and then successfully tested it with the MySQL browser. I then updated my OscMax package with the latest patch and began the OSCMax install. When it gets to Database Import, I fill in the MyPHP server, user, and database info and I hit the submit button. The lower 3/4 of the screen goes blank leaving the upper graphic and text, but the app just hangs. Windows Task Manager indicates the installer is running, but nothing happens after letting it run over an hour.

I have followed the installation instructions carefully and have tried numerous suggestions from the forum posts. So far nothing has helped. Has anyone solved this one???

Thanks -- Gene Kinum

Geno11x11
12-03-2005, 06:03 AM
Further info on this problem:

Apache2, PHP5, and MyPHP4 all work by themselves, however there is a broken link between PHP and MySQL.

I attempted to connect to the MySQL database with PHP and received the error message: "Fatal error: Call to undefined function: mysql_connect() in c:\...". Researching this error, I learned that it is likely caused by a missing connection with php_mysql.dll and a number of other library files. I followed directions on entering the extension with the explicit path in php.ini and the path in the Windows XP environmental variable. I even moved the library bundle around to %sysroot% when the extension entry in php.ini failed.

I then ran phpinfo() and found no references to MyPHP. Further, I noticed that many of the configurations are not reflected in the phpinfo() display, such as register_globals, register_long_arrays, Configuration File (php.ini) path, and the include_path. In short, no changes I make in php.ini affect phpinfo(), yet I know php.ini is being accessed by PHP because phpinfo() fails if php.ini is renamed.

I am inclined to think the primary difficulty lies in PHP since it is not being configured by the parameters in php.ini. It would follow that PHP is not connecting to MySQL since those parameters are not being recognized.

I am hopeful someone has the "simple solution". If not, I will delete the PHP installation and try a re-install in hopes of gaining parameter control. As always, any help will be greatly appreciated.

Gene Kinum

jpf
12-04-2005, 10:27 AM
Did you use a WAMP package? Or manually install them separatly? (which if not done in the proper order or not done correctly can cause proplem like what your having)

If SEPARATELY - Suggestion: REMOVE/UNDO everything - Install a WAMP - Like EasyPHP (which has a nice single control panel with an easy ON/OFF/RESTART option) - which I use alot!.

?AMP where ? is a (L)unix, (W)indows or (M)ac with Apache, MySQL, PHP single install package.

Some Popular WAMPS:
EasyPHP
Apache2Triad
wampserver.com
AppServ
PHPTriad for Windows
WinServ

Other - I have not tried/looked into:
FoxServ
The Uniform Server - www.uniformserver.com
TSW [The Saint WAMP]
Aweris WebServer
Easy Web Server
Reactor Server
IBserver

And many more......

Each "package" include slighly differnet version and some package some other tools (most also have phpmyadmin). One install - ALL CONFIGURED TOGETHER.

Good Luck