PDA

View Full Version : Packingslips



Cisco
09-28-2005, 03:21 PM
I am getting the following errors when I go to print the packingslips.

There is no issue with the invoice missing any information.

Does anyone have any ideas?

Shipping Method:
Fatal error: Call to undefined function: tep_get_orders_shipping_method() in /home/content/C/i/s/Cisco281/html/XdomainX/catalog/admin/packingslip.php on line 113

Cisco
09-28-2005, 04:40 PM
Can someone please check and compare the code on line 113?

This is my code:

admin/packingslip.php
<td class="main"><?php echo tep_get_orders_shipping_method($oID); ?></td>

timbrrr
09-29-2005, 05:45 AM
I had this same problem and tried removing line 113 in the packing_slip file and it seemed to work after that. I dont know if that was the right thing to do, but it did the trick for me. Try it if you have a backup copy to put back in its place if it goes awry. If someone else has a better suggestion, I'm all ears.

Cisco
09-29-2005, 06:57 AM
I did the same thing, but it still does not resolve the issue. There is still data that is to be present or needed.

rgsat
09-29-2005, 06:57 PM
SAME THING HERE!!! I have v2.0 rc2 installed using the UPS XML module. :help:

Fatal error: Call to undefined function: tep_get_orders_shipping_method ....... /admin/packingslip.php on line 113

michael_s
09-30-2005, 06:22 AM
Try removing the tep_get_ from the function name... It may just be orders_shipping_method

I have not tested, but it may be worth a try.

If that does not work look at the packingslip mod install instructions and see if it has a function named tep_get_orders_shipping_method that is installed somewhere and make sure it is installed.

When I get a little time that is exactly what I am going to do...

Cisco
10-02-2005, 10:52 AM
Thanks for you r reply!

I tried that and it did not make it work.

I have been going through the ship mod and have found nothing as of yet.

uli_nyc
10-09-2005, 01:57 PM
Hi,
I am getting the same error, tep_get_orders_shipping_method($oID) is a call to a non-defined function. I tried looking through various contributions for packing slips, as Cisco before - same result. I also checked the tep_database-pr2.2-CVS.pdf for what the function might be called. shipping_method($oID) look reasonable from that.

However, when I varied the call step by step, no luck:
get_shipping_method($oID)
shipping_method($oID)
tep_shipping_method($oID)
etc...

Any thoughts are appreciated.

Smurf
10-28-2005, 01:25 PM
I'm getting the same errors.

Has anyone found the answer yet?
Ta

landshark
10-30-2005, 03:04 AM
I am also having the same problem.

landshark
11-04-2005, 12:13 AM
no fix on this yet I take it

uli_nyc
11-04-2005, 04:02 PM
See http://bugtrack.oscmax.com/view.php?id=95
for progress updates on bug fixes.

uli