PDA

View Full Version : No CC modules showing at checkout.. urgent!



dixxy
08-25-2005, 09:03 AM
Hello,

I have installed several OsCMax 2.0 shops, but on none of those (even on different servers) the credit card modules show up on checkout.

All other modules like COD and such can be installed/uninstalled without any problems and show up at checkout, but not the CC modules..

Does anyone have a clue what i did wrong? (it works on v1.7)

ganast
08-25-2005, 12:04 PM
be more specific... are you talking about the actual "Credit Card" Payment option, or are you saying "any payment option that takes Credit Cards"

I am experiencing an interesting issue myself trying to install PayPal Web Payments Pro... it could possibly be related.

Tell us specifically what you are seeing on one of your shops and then how is the same or different on other shops...

--gabe

dixxy
08-25-2005, 12:14 PM
Well, i mean any payment option that take CC, the standard payment options like PayPal or Authorize.net is the ones i try to get to show up when i come to the second step in the checkout process (checkout_payment.php)..

Right now only Cash on delivery is showing, this one i can remove/add without any problems, but not the other modules..

Its almost like the script dont realize that the CC module (paypal for instance) actually is installed..

ganast
08-25-2005, 12:52 PM
yeah... ok, next question: have you installed many/any of the patches in bugtracker?

--gabe

dixxy
08-26-2005, 02:31 AM
I have installed all completed fixes:

- 0000012: Authors box
- 0000016: Wishlist
- 0000036: SQL, Tax & Button
- 0000029: Tax display
- 0000003: Affiliate Account
- 0000007: Admin Emails
- 0000011: Product Listing Coloumn (også id 25 & 29)
- 0000046: Default Specials Box
- 0000048: Paypal IPN Tax
- 0000041: Fedex Tracking
- 0000026: Shopping Cart Fix
- 0000017: SQL Search Error (SQL query)
- 0000010: Linkpoint fix
- 0000015: Product price mismatch
- 0000021: Order info process
- 0000009: Main page template
- 0000002: Checkout Process
- FCKEditor Fix
- Popup_image.php moderasjon
- 0000043: Feature, not error
- 0000028: Restock quantity
- 0000053: Update of fix 0000018
- 0000052: Bugfix for admin_account.php
- 0000054: Update of bugfix 0000052
- 0000058: Update of fix 0000015
- 0000023: Admin edit orders fix
- 0000056: Issue fixed by 0000012
- 0000047: Discount coupons
- 0000057: Printable catalog
- 0000037: CC Card validation
- 0000036: SQL, Tax & Button

You can log in to my customers shop at www.whyitwork.info and try a checkout procedure (only in norwegian). You will find that only two payment options is available, because when i add PayPal or other CCs it dont show up.

ganast
08-26-2005, 06:34 AM
This is an odd one... this is how I would start to debug it though... Un-install all credit card modules and just install the basic "Credit Card" module.

If this works, uninstall it and install one of the ones you have currently installed... If this does NOT work, try each of the other credit card modules you currently have installed one at a time... do any (either) of them work?

If not, it is probably a change/changes in those modules... diff them (use beyond compare, or winmerge) against the originl files. If its not there, maybe it is a problem in the database, or possibly a problem in /includes/classes/payment.php

--gabe

ganast
08-26-2005, 09:09 AM
One other thing it could be is that you have defined a payment method for a certain customer class, and that (list of) payment method(s) does not include the credit card classes that you are using...

Check here:

Admin > Customers > Customer Groups > Edit

the "Payment Modules" section should be completely blank for default values...

--gabe

dixxy
08-26-2005, 09:31 AM
Thanx Gabe / Ganast :D

I really cant thank you enough for telling me this. I guess i should be reading the new docs, but when i was used to the 1.7 version I thought i knew just about everything, but i didn't.. :shock:

Well, now all works fine 8)

Thanx again!