PDA

View Full Version : Catalog (page not found?)



sean747
07-20-2005, 01:23 PM
Hi there,

I installed osCMax on my server and everything worked fine for a while, but then the index.php page stopped working, or I should say the whole store. Everytime I type in the url address, I get a "page not found" error eventhough the pages are there and still in my server.

The admin panel still works fine and I could login to the admin and still change settings and everything, but I can't view the store,

anyone know what could be the cause of this? should I try reinstalling?

jpf
07-21-2005, 04:50 AM
What changed? If it worked before and now it does not then something was changed (NOT OSC related). Check with your host to see if anything was upgraded/changed.

ozmatic
07-22-2005, 10:28 PM
This problem has arised for me too. Store was working perfectly after installation. when I entered a new catagory the whole store stopped working. Admin works in the mean time. When I delete all the category and products store works again.

tbone
07-22-2005, 11:18 PM
funny you would mention that, I had a similar experience. I figured I must have screwed up but never did figure out what happened. It was a fresh install. It ran OK for about a day and then went kerplunk after minimal configuring. Same symptoms couldn't find catalog/index.php but it was there. I reinstalled and haven't had that problem again. I have installed OScommerce dozens of times so I am pretty familiar with the installtion.

server specs:
PHP 4.3.8 W/ Zend Optimizer
MySQL 4.0.22

michael_s
07-23-2005, 06:07 AM
You are turning on the standard osC cache. Turn it off and use the new 'page cache' instead. The standard osC cache has problems with the BTS system.

islander
07-30-2005, 02:36 AM
The same has happened to me.

I checked the admin and the standard cache was still set to off.
I then enabled the 'page cache' option, but still no go.

Is a re-install mandatory?
If there is a known issue with the cache and BTS, shouldn't these settings be preset by default?


OK, just deleted all catagories as mentioned above, and catalog re-appears, but new with the 'page cache' enabled, I end up with cache errors in the footer.



Warning: fopen(/home/user115/public_html/programas/catalogo//cache/_programas_catalogo_index.php__english_USD.cache): failed to open stream: Permission denied in /home/user115/public_html/programas/catalogo/includes/classes/page_cache.php on line 261

Warning: fwrite(): supplied argument is not a valid stream resource in /home/user115/public_html/programas/catalogo/includes/classes/page_cache.php on line 262

Warning: fclose(): supplied argument is not a valid stream resource in /home/user115/public_html/programas/catalogo/includes/classes/page_cache.php on line 263
[quote][/quote]

ganast
07-30-2005, 07:54 AM
How many categories did each of you have? One category? If you only had one (for testing purposes), there is an error in the articles box that more or less kills the store if you only have one category. (this comment does not apply to the OP, that is a different issue)

Add at least two categories, or turn off the articles box until the bug is found.

--gabe

islander
07-30-2005, 11:02 AM
I have three categories with one sub-category.

the errors still persist.

I dont want to start adding too many things, just incase I have to delete everything again to see the main page.

ganast
08-01-2005, 09:47 PM
You need to set proper permissions on the cache directory... the webserver cannot write to it... try adding write permissions for group, this sometimes works depending on your server setup.

Note also that you might need to edit the config.php file as there is a / prepended to the cache directory... notice the "double //" in the first error statement. In osCommerce, all the directory constants end in "/" (well, almost all...) so you are getting an extra "/" from somewhere... it actually should not matter, but some webservers will choke on that...

--gabe

michael_s
08-04-2005, 08:01 AM
This may be related to the Authors box bug. A bugfix has been released for it, so please download apply the patched file and see if it resolves this issue:

http://bugtrack.oscmax.com/view.php?id=12

[wicked]
08-09-2005, 03:51 PM
I have now hit the same problem, I have downloaded the author.php fix Micheal but, where do I stick it? lol, be nice ;)

michael_s
08-09-2005, 04:05 PM
As it says in the bug report:

Download the attached file, unzip it and then upload to your /catalog/includes/boxes directory, overwriting the authors.php file.

[wicked]
08-09-2005, 05:09 PM
It all works good (i d/loaded the new author + added categories) now apart from this code at the bottom of my index page.


Warning: fopen(/home/fruityb/public_html/store//cache/_store_index.php__english_GBP.cache): failed to open stream: Permission denied in /home/fruityb/public_html/store/includes/classes/page_cache.php on line 261

Warning: fwrite(): supplied argument is not a valid stream resource in /home/fruityb/public_html/store/includes/classes/page_cache.php on line 262

Warning: fclose(): supplied argument is not a valid stream resource in /home/fruityb/public_html/store/includes/classes/page_cache.php on line 263

any ideas?

michael_s
08-09-2005, 10:46 PM
make sure you have a /home/fruityb/public_html/store/cache/ directory and it is chmod 777

[wicked]
08-10-2005, 02:36 PM
once again Michael, you da man! :)
It was not set right, I did set it before but my ftper (cuteftp) was corrupted and not setting chmod's, I am now using ftpCommander and all is goooooood! (for now)

Thanks again.

HipHopServers
10-10-2005, 08:46 AM
Well my issue is simular but it is http://(www.)mydomain.com vs http://mydomain.com the url without the (www.) works fine but the urls with (www.) doesnt work. How do I dix it so it works with and without the (www.) perfix.

HipHopServers
10-10-2005, 09:13 AM
Well I figured out that my issue was related to the caching issue and the fact I had the standard OSC cache set to true. As discribe in this thread I made it false and made page caching true this resolved the issue I was having with the page loading.