PDA

View Full Version : SEO Friendly HTML links in URL



librianguy
07-15-2005, 08:26 AM
Hi,

Im facing a problem of converting the url to seo friendly... i need to have the url to be ending with .html rather than cName or pName .... can anyone tell me how to do it im using OscMax v2...

Help appriciated
Regards
NAdim

rahulbaba
01-28-2006, 02:33 PM
Well you need a Mod_rewrite for this. I am searching for the same solution but havent found for OSC Max yet. There are several solutions available for the similar scenerio in OsCommerce

groggory
01-28-2006, 03:15 PM
I have it working in my beta Store right now...

take a look at this...

http://www.upupandawaykites.com/e2-p-1.html

configuration>seo urls>enable seo urls

then in your root, you're going to have to uncomment the stuff applying to your situation from the .htaccess file

c.h.u.d.
01-29-2006, 12:03 PM
Yep, it works for me too, set up exactly the same way as groggory suggests.

Redeye_Joe
01-30-2006, 12:12 PM
then in your root, you're going to have to uncomment the stuff applying to your situation from the .htaccess file

Can you please explain in more detail, I am not to familiar with how htmaccess works. I usually set it up via my vdeck or cpanel...
thanks
Doug

groggory
01-30-2006, 01:50 PM
The root of your site is the lowest level. For instance:

/home/yoursite/www/www/ ---- this could be your root, equivelant to
http://www.yoursite.com

Download a copy of OSCMAX, there is a file in the lowest catalog level called '.htaccess'. You need to open that using a text editor and remove the '#' signs next to lines that apply to you. Then FTP the .htaccess file back into your root.

Read the file and you'll understand. It is written very clearly.

If you would like a good text editor, I prefer a program called 'textpad', you can find it here at download.com (http://www.download.com/TextPad/3000-2352_4-10303640.html?tag=lst-0-1). It is a demo version, but it has full functionality with a nag screen at startup.

Take a look and I'm sure you'll understand.

Redeye_Joe
01-30-2006, 08:12 PM
I think I figured out htaccess. I uncommented the part that applied and changed my folder name. Do I need to uncomment the first line in the file also, that is the only thing I can think of unless I need to set it to reset in the admin.
I have it set to
Enable SEO Urls? True
Choose URL Type: Rewrite
Filter Short Words: 3
Reset SEO URLs Cache: false

I have it in what I think is my root, i see other htacess files in there with a .number extention. Anyone know what else it could be,
also I checked and my server has MOD_rewrite
thanks for any ideas?

groggory
01-30-2006, 10:16 PM
why did you change your folder name? what folder?

Redeye_Joe
01-31-2006, 09:15 AM
I have mine installed to catalog/ so I put /catalog/ in where the /folder/ was and uncommented that block of code, as it say to. From what I read that applies to my situation, or is that for only if you have your catalog in like /example/catalog/.

Redeye_Joe
01-31-2006, 11:19 AM
I got it working, i upgraded to seo 2.2.1e and all is good now, working fine
:)

groggory
01-31-2006, 12:25 PM
are you running the latest MAX?