PDA

View Full Version : PWA_0.82 for oscMAX1.7



ganast
01-26-2005, 01:09 PM
Here is an upgrade of the sort of buggy PWA that is currently in oscMAX1.7.

oscMAX1.7 claims to have PWA_0.7 installed, but the code looked like a later release... could not exactly tell. In any case, here is the 0.82 version ready to install.

In this tarball you will find three directories:

catalog [this is the vanilla install set for plain osc that is from the contrib found here (http://www.oscommerce.com/community/contributions,355/category,all/search,without+account)]
oscMAX17+PWA82 [this is the drop-in file set for oscMAX1.7]

oscMAX17_bak [this is the file set that I presumed to be oscMAX1.7 - in other words, I may have tweaked a file or two and not realized it... if you have problems, do a Beyond Compare on these files and the corresponding files from the oscMAX1.7 tarball. They should be identical! If they are not... it means that I contaminated an oscMAX1.7 file, and the "contamination" will also be in the drop-in set in the above oscMAX17+PWA82 directory. Edit the "contamination" out and you should be good to go.]

I may have screwed something up here, but it looks good on my client's site... btw there is NO NEED to update any sql, or to ALTER and db tables or columns.

oops... you do have to add this column:

ALTER TABLE orders ADD purchased_without_account TINYINT (1) UNSIGNED DEFAULT '0' NOT NULL;


--gabe

PS: I just forgot, I have quite a few changes in the language file english.php that are not PWA related... not the least of which is my client's company name, No Greater Joy... so, remember to change those!

michael_s
02-16-2005, 08:32 AM
Thanks for the contribution!

I have not had a chance to test it, but I will probably be updating the osCMax package to include this.

red_fraggle
03-03-2005, 05:40 PM
on a clean install of OSC-MAX 1.7 i get the following error after creating a test product and trying to use PWA to buy it.



1062 - Duplicate entry '7' for key 1

insert into customers_info (customers_info_id, customers_info_number_of_logons, customers_info_date_account_created) values ('7', '0', now())

[TEP STOP]


anyone have this happening?

humet
04-18-2005, 11:45 AM
I can't even d/l the file. Or any file from this forum infact! I click the link and it loads a webpage with a load of jumbled up txt???

Any ideas??

humet

michael_s
04-18-2005, 02:38 PM
humet : That is a problem with your browser. Looks like your browser does not support gzip compression.

humet
04-19-2005, 04:36 AM
Stupid IE! Just tried d/ling in Firefox and works perfectly. I've been meaning to change to Firefox for a while anyway! Loads better IMO!

Anyway, nice contribution. Works perfectly. I couldn't get the original PWA that is supplied with OsCMax to work, but, I tried this and bingo!

thanks

humet

michael_s
04-19-2005, 06:12 AM
The PWA installed in osCMax is active and working by default when you make a clean installation. There is nothing else needed. This mod is still a big improvement though!

tbond4
09-28-2005, 02:47 PM
The PWA installed in osCMax is active and working by default when you make a clean installation. There is nothing else needed. This mod is still a big improvement though!

Hi,

I'm using OscMax 1.7 with the osC template that comes ready to use. See the non-live store install at http://www.americal.com/catalog/

There isn't any PWA option working in this template.
I don't see anyway to 'turn on' the PWA mod. Where do I find it?

If not installed, how do I install it... is this mod the one to use with the osC template and 1.7 ?

Thanks. :wink: