PDA

View Full Version : php error



judoka
11-18-2004, 04:21 PM
hi guys,
I just upgraded my easyphp from 1.6 to 1-7 but now when I try to open up my website on my localhost, I am getting the following error:

"FATAL ERROR: register_globals is disabled in php.ini, please enable it!"

Does anyone know how I can fix this problem?
thanks for your help.

michael_s
11-19-2004, 06:07 AM
set register_globals to On in php.ini...

judoka
11-19-2004, 02:06 PM
set register_globals to On in php.ini...

HI Micheal, Thanks for the reply; but which php.ini? I found 4 php.ini that I can think of and I turn all 4 to "on" before I place this post, but I was still getting the error message which is why I place this post. Can you please be a little more specific as to where to find the correct php.ini?

Thanks Micheal

judoka
11-22-2004, 09:22 AM
Any body knows which php.ini I need to go to in order to turn on the register_globals. I need this as quickly as possible. Any help would be greatly appreciated. Thank You.

michael_s
11-22-2004, 01:51 PM
I suggest changing all of them. It will only take a few minutes. Then restart apache for the change to take effect.

judoka
11-22-2004, 03:27 PM
I suggest changing all of them. It will only take a few minutes. Then restart apache for the change to take effect.

Hi Micheal,
I did change all of them however it didn't fix the problem however I decided to do a re-install and that fix the problem. Go figure. :?

I do have another question that I just notice today. I am redoing my website and I have bought a complete template store from TemplateShopper.com due to a lack of redesign time, which come with the os system built in. However I have notice that when I go to the admin. it is not password protected nor is there anywhere in the admin where I can set up a user name and/or password. My question is, is there anyway that I can add this feature to my admin?

Geno11x11
11-18-2005, 01:49 AM
Apache2, PHP5, MySQL running on WinXP
Application: OScMax v2

Despite turning register_globals on and restarting Apache, I am getting the following error when running catalog\install\index.php:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

Any suggestions on confirming whether or not register_globals are really on or off, or how to resolve this problem?

Thanks,

Gene K.
[email protected]

michael_s
11-18-2005, 09:32 AM
Gene, if you are getting that error, you in fact have not turned on register globals. Check to make sure your host has not disallowed you changing this value, and also make sure you are editing the correct php.ini file.

Try killing all apache processes by doing a killall -9 httpd and then starting apache again and see if that helps.

Geno11x11
12-01-2005, 03:17 PM
Thanks for the suggestion. I got past this one using .htaccess files which did succeed in activating register_globals.

Still at the installation, I am now stuck at the Import Database stage. After filling in the fields and submitting, the lower 3/4 of the screen goes blank and it hangs. I need to identify if my problem is in the MySQL database setup, in PHP configuration, or perhaps it is a rights issue. How do I troubleshoot this?

I have not taken the easy way - installing PHP4 - because I am taking a PHP5 class and the instructor advised me to install the later version. Other OSCMax users seem to have gotten the package up and running on PHP5, but I have only found snippets of information and no comprehensive list of solutions. Is is it worth the time and trouble going this route?

jpf
12-04-2005, 09:45 AM
Rights issues - maybe, check the user permission in mysql (use phpmyadmin). Web root error - maybe (you may have to put the file into c:\install\osCMax.sql - don't know why but ran into that myself with some WAMP packages)

If it is just the import that is stuck (connection was fine) - then SKIP it....use phpMyAdmin and load the above file into the SQL query and run it....

Good Luck!

jpf
12-04-2005, 09:47 AM
Oh and about PHP5 yes you can run osCMax 2.0 RC2 with patch applied! This is one of the issues that the patch delt with!