PDA

View Full Version : sales tax question



greg
01-27-2003, 08:16 PM
:?: I changed sales tax to 6% but it shows 16% when I try to buy something. Anyone knows what is wrong ?

greg
01-28-2003, 08:39 AM
wake up guys I NEED HELP !!!!!!!!! :!:

greg
01-28-2003, 08:49 AM
Sales tax is set only for NJ at 6%
When I try to make a purchase with (for example) NY zip , it still charges NJ tax. Another funny thing is that I set NJ tax at 6% and it charges 16%.
If anyone can help, I really appreciate.

michael_s
01-28-2003, 09:47 AM
Did you setup your taxes as per the instructions in the oscdox guide? Double check your settings. If you do it per the guide, you should have no trouble.

If you have done it per the guide, have you added any modifications that we should know about? Or is this a clean installation?

greg
01-28-2003, 04:03 PM
I did it again just like the guide says. Same thing ...... I enter 6% but it still showing 16%. It should charge tax only to NJ residents but it charges 16% for all states.............

greg
01-28-2003, 04:27 PM
:twisted: when I "buy" as a NJ customer it shows 6% now (which is correct), but everybody else pay 16%. Now I'm really confused

judoka
11-04-2003, 10:35 AM
I seen to be having this same problem. :? I have my setting set to collect taxes for Texas only, yet when I make any test purchase taxes are added for all states I enter. :? . Anybody know what is causing this problem?

michael_s
11-04-2003, 10:48 AM
This means you missed a step somewhere along the way when setting up your taxes. Delete all tax info (ALL of it) and start over.

judoka
11-06-2003, 05:05 PM
Hi MSasek,
I deleted everything under the Locations / Taxes as you suggested but it didn't fix the problem. The Texas taxes are still being added to every state I make a test from. Any other suggestion?

WebMistress
11-08-2003, 06:47 AM
Seem to be having a similar problem myself.

I set Indiana as the Zone ,set the Tax Rate, and made sure the Class is right, but it is still showing Tax on everything marked Taxable Goods, even when NOT logged into the cart, at the regular Indiana rate.

The amount is correct, but it should't be showing for even those Not in Indiana, right?
As SOON as I click Taxable Goods on the product entry, it goes immediately into showing the taxed amount.

How do you get the Zones to correctly display the Taxes?

Anyone figure this out yet??

michael_s
11-08-2003, 09:52 AM
It is really not that hard. I just follow the guide step by step and it works every single time :

http://guide.oscdox.com/osCommerce_Administration_Manual/Admin__Taxes_Setup.htm

WebMistress
11-08-2003, 11:54 PM
GAH it logge dme out
blah
gotta do it again.. KNEW I should have copied before I hit post..

anyway

I followed as close as I could since my setup was a bit different than that guide shows. I will show what my settings are.

In Tax Zones, if I click details it gives me this:
Country=US
Zone=Indiana

Tax Rates:
Tax Class=Taxable Goods
Zone=Indiana
Tax Rate=6%
Desc=IN Tax Rate 6%

but then it shows this:
"Tax rates at the same priority are added, others are compounded."
Priority=1

Could THAT be something to do with it not showing right?
I couldnt find anything referring to that, so I left it at the 1.

Even changing it to 0 didnt make a difference :<

I dont mean to be a pain, though the rest of the guys either are still having probs, or they didnt post their findings

judoka
11-09-2003, 02:14 PM
HI Msasek,
I deleted all my Tax files again and follow the admin setup text step by step but I am still having the same problem. Taxes are still being added for all states.

michael_s
11-09-2003, 03:06 PM
judoka, this means you missed a step. If you make a temprorary admin login for me, I will take a look for you...

WebMistress
11-10-2003, 02:20 PM
::smacks self in head repeately::

Um
I found why it was showing the Tax ALL the time...

On the My Store section, there is this pretty little bar that asks
"Display Prices with Tax true "

As you can see, THIS is where it was coming from
Happened to see another post elsewhere asking if someone had that set in the admin after scouring through file after file looking for tax references.

Well, I fixed MY problem, I hope!!

Sorry Im such a dork!

michael_s
11-10-2003, 11:13 PM
WebMistress, and from your post, I had no idea that was your problem. I thought your problem was that during checkout taxes were being shown and calulated for everyone...

If you had only said, "prices are displaying with tax included" ;) See how narrow my focus is :)

superman
11-11-2003, 07:57 AM
It is really not that hard. I just follow the guide step by step and it works every single time :
http://guide.oscdox.com/osCommerce_Administration_Manual/Admin__Taxes_Setup.htm

Thank you so much for the link. I was pulling my hair trying to figure out why my tax rate wasn't working properly.

judoka
11-11-2003, 04:35 PM
judoka, this means you missed a step. If you make a temprorary admin login for me, I will take a look for you...


Hi Msasek the temprorary login that you had setup for yourself when you install the pre-release MS2 on my site should still be good. I never deleted it. Try it at www.GiftsUniqueShop.com/ms2/admin

Thank You Msasek,
Judoka

michael_s
11-11-2003, 09:01 PM
judoka, there is definitely something broken in your cart. I tested it in a stock MS2-MAX 1.5.2 and taxes work correctly, but yours do not work. It is not updating the DB correctly. You may have inadvertantly mucked up the taxes code. Finding the problem will be like looking for a needle in a haystack... Check your error logs first, and see if anything shows up there.. I doublt it, but worth a check.