PDA

View Full Version : Cannot send any emails



bisiot
08-06-2004, 08:54 AM
Hi

I have tried al combinations of SMPT , LF etc, but no emails are received but OCS_MAX says they are sent OK.

My hosts says to use SMPT.

I read somewhere that they found their A records where not set up correctly. What exactly are A records and what should the set-up be.

Otherwise everything installed OK, but without emails I am dead in thew water.

Is there a lifeguard around? Blub...blub...

Arpit
08-06-2004, 09:23 AM
An A record gives you the IP address of a domain.

There are few ways to check if your "A Records" are correctly set,

http://www.rscott.org/dns/a.html

see if that helps :idea:

bisiot
08-06-2004, 10:05 AM
Thanks

I did a look up and got

DNS Lookup: dragonmoon.ca A record
Generated by www.DNSstuff.com
How I am searching:
Searching for A record for dragonmoon.ca at m.root-servers.net: Got referral to NS-EXT.VIX.COM. [took 195 ms]
Searching for A record for dragonmoon.ca at NS-EXT.VIX.COM.: Got referral to e20ns1.dns-he.com. [took 100 ms]
Searching for A record for dragonmoon.ca at e20ns1.dns-he.com.: Reports dragonmoon.ca. [took 92 ms]

Answer:


Domain Type Class TTL Answer

dragonmoon.ca. A IN 14400 66.225.255.131
dragonmoon.ca. NS IN 14400 e20ns2.dns-he.com.
dragonmoon.ca. NS IN 14400 e20ns1.dns-he.com.
e20ns2.dns-he.com. A IN 135379 66.225.255.132


Should I be concerned about two IP being shown here?
66.225.255.131
66.225.255.132

Thanks

Arpit
08-06-2004, 10:37 AM
well now that you know ur "a records" are correct, use phpInfo() to look up your php configurations, look for SMTP local and master values and smtp_port, if that looks correct, create a test script to send a mail, somethin like:



if(!mail([email protected],subject,message))
echo "Mail Not Sent<br>";
else
echo "Mail Sent<br>";

alteast that should tell you if your server is configured correctly to handle outgoing mails. :idea:

bisiot
08-07-2004, 06:43 PM
I think I found out what it is. This may help others who can't send emails, or at least receive them from OSCommerce.

I had another SMTP server for my mail, not the SMTP server my oscommerce was on, but the domain name for my email was on the same server.


But if you send emails from the same server where your account is set
up, all these emails go to the main account, not to the server where your
MX record is pointed. Local delivering has higher priority, so all your emails from this
scrip went to the account on the main server.

Solution. Change the SMTP server to be the same as the domain name.

It will take a few days for this to take effect but I believe this will solve the problem.

choonhooi
10-31-2004, 11:23 PM
Hi, I just setup my online store (based on OSCommerce) in my webhosting server. I tried doing some purchases to test out the system. I managed to do a purchase, but I dont seem to receive any email notification about the sales/purchases, both for the purchaser and the shop owner. I already set the email address in the admin page. I think this is mainly due to the email server setting (maybe??)

I would like to know where can I set my email server acct (i.e SMTP server name). I cant find any option in the admin page to allow me to key in my smtp server name, login name and password.

Really appreciate some help on this. TQ.