PDA

View Full Version : search.tpl question - line feed pushing textfield down



jhdesign
07-12-2004, 08:02 AM
I'm working on this site now:

http://www.myidealgift.co.uk/index.php

Have a look at the top left, the search box.
Its pushed down as if there was a line feed there, I'm not sure how to fix this.

There seem to be no line feeds in search.tpl or in the actual main_page.tpl.php

Any help is appreciated.

jpf
07-12-2004, 12:21 PM
I can see it when I "view source"...


<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

<body bgcolor="3D3D3D" leftmargin="0" topmargin="0">
<br> <==**** Right here! ************
<table width="100%" border="0" cellpadding="0" cellspacing="0" background="images/top_bg.gif">
<tr>
<td width="43%"><table width="300" border="0" cellspacing="0" cellpadding="0">
<tr>
<td width="81"><img src="images/top_search.gif" width="81" height="27"></td>
<td width="200" valign="top">
<!-- search //-->
However Since php is proecessed I can't help much. Try to compare the "view source" and you code to trace down where the extra <br> comes from.

Good Luck

jhdesign
07-12-2004, 05:20 PM
Its actually not that. That BR pushes the whole site down a bit so you can see the dark grey at the top.

The seach area starts at the last line there with <!-- search //-->

I've done this type of setup on basic OSC and works fine, but here I get a line feed.

Anyy other ideas?

jhdesign
07-13-2004, 07:02 AM
Fixed it.

Modified the include/boxes/search.php and put in the search button manually (which caused the height issue)