PDA

View Full Version : Upgrade 2.0.25 t0 2.5.2 issues - Admin Access but no Site - MIssing modules and Site Mtce access



giga009
09-15-2012, 08:04 PM
Hi have followed all the instructions on how to upgrade from 2.0.25 to 2.5.2 I have access to the admin and it says 2.5.2 however I have the following issues:


1. Front of cart says:
1054 - Unknown column 'pm_cg_hide' in 'field list'

select
pm_filename, pm_active, pm_page, pm_cg_hide, pm_sort_order from
pm_configuration where pm_page = 'index' and pm_filename <>'' and
pm_active = 'yes' and NOT find_in_set('0', pm_cg_hide) order by
pm_sort_order

[TEP STOP]

---------------------------------------------------

2. I have no "site mainentance" under administrator in admin (can't check ip or place site back into main mode)

3. have no module drop downs to reset the payment or shipping modules?



Any Suggestions would be greatly appreciated as I don't know what else to check?

There were no errors in upgrade and I got to the point where it said already upgraded to 2.5.2 can't upgrade anymore

Thanking you in advance

Giga

giga009
09-15-2012, 11:15 PM
Update:

Have turned on error messages for both admin and cart and find the following when trying to log into admin:

Notice: Use of undefined constant
FORCE_ADMIN_LANGUAGE - assumed
'FORCE_ADMIN_LANGUAGE' in /home/xxxxxxx/public_html/catalogue/admin/includes/application_top.php
on line 124



Warning: Cannot modify header information -
headers already sent by (output started at
/home/xxxxxxx/public_html/catalogue/admin/includes/application_top.php:124)

in /home/xxxxxxx/public_html/catalogue/admin/includes/functions/general.php
on line 107

------------------------
Also I have uploaded a fresh copy of 2.5.2 under another name eg shop and copied my configue files both normal and admin, to this completely new 2.5.2 and the same issues are apparent. Therefore I can only assume that the issues are within the actual database itself although I don't know where to start looking in the database to rectify the issues I am experiencing.

I am also missing some drop down menus under configure as there is only Google Maps there , should there be more?


Look forward to any assistance. :)


Regards
Giga

pgmarshall
09-20-2012, 04:24 AM
Have you run the upgrade script?

Looking at the error message in your first post you have missed 2.5.1 to 2.5.2 sql upgrade.

Check in admin panel for administrators -> upgrade system.

If it says you have already done this then run the script manually ... Open phpmyadmin and cut and paste in contents of 2.5.1_to_2.5.2.sql file you can find in the 2.51 upgrade to 2.5.2 changes only zip file on download page.

Error reporting in admin will cause the headers already sent as you are missing the define created in this script.

Regards.