PDA

View Full Version : MailChimp Sync error



Pr0ject
02-02-2012, 12:58 AM
when i click mailchimp sync
i get the following error
Unable to load listMembers()! Code=501 Msg=Invalid Date Time (re): "01/01/01 12:12:12" Members returned: 1 Unable to load listMembers()! Code=501 Msg=Invalid Date Time (re): "01/01/01 12:12:12" Members returned: 1
now if I don't enter a time into the mailchimp last sync field I don't get the error but I also don't get any user names synced either...

am I doing something incorrectly?

pgmarshall
02-02-2012, 07:21 AM
am I doing something incorrectly? YES. MailChimp Sync button is in the Customers page ... the field in the settings gets filled when you run it. It is editable in case you want to clear the data NOT to sync. Regards.

Pr0ject
02-02-2012, 09:50 AM
so i cleared the date hit sync and it says 0 customers synced. i have some customer who are subscribed to the newsletter but no emails are synced....

pgmarshall
02-02-2012, 10:49 AM
Are they already on the list? Can you check your MailChimp account?

Thanks.

Pr0ject
02-02-2012, 11:15 AM
my mailchimp account is empty. I thought the api was suppose to populate it from my oscmax customers db.

pgmarshall
02-02-2012, 12:04 PM
It is! It worked last time I used it. You have your API keys in properly don't you? I don't see where it is getting the time from - which is what it looks like it is unhappy about.

Pr0ject
02-02-2012, 01:27 PM
The time is left blank from the config->mailchimp newsletters, and it syncs fine i guess but it says 0 added and 0 deleted.

pgmarshall
02-02-2012, 01:41 PM
Once it has sync'd does the date stamp appear in the admin section?
Do you get any message at the top of the screen?

Regards,

pgmarshall
02-02-2012, 01:44 PM
I have checked the MailChimp API and the error is because the timestamp is invalid ... as stated in the error message.

Can you sign up a test customer and select the newsletter option and see if that registers them to the MailChimp list?

Thanks.

Pr0ject
02-02-2012, 02:04 PM
yes creating a new account works, but the sync feature has not added the old emails into the mail chimp list

Pr0ject
02-02-2012, 02:06 PM
so i went into the customer database in oscmax and unsubscribed someone then clicked sync and it subscribed that customer. Is that the way the sync is suppose to work? I want the oscmax to populate the mailchimp list... Should I just go about that manually?

pgmarshall
02-02-2012, 02:44 PM
???

When you unsubscribed someone the Sync subscribed them? No - the opposite. (But at least you have it passing the details to MailChimp - so that is a start!)

Can you explain in very clear steps what you are doing as I am struggling to replicate any of this on my test store. If there is an issue then I want to fix it but I can not seem to get what you are.

You can do it manually if you want - but that is not the point. osCmax should handle all of your subscriptions/removals automatically(if you want it to).

Thanks.

Pr0ject
02-02-2012, 02:51 PM
okay so i signed up a new customer and oscmax subscribed him.

now I manually unsubscribed him in oscmax.

I hit mail sync and it resubscribed him. Basically treating mailchimp list as the master list and the oscmax as the slave list.

None of the previously subscribed cusomters passed over to mailchimp.

lemme know if you need further clarification