PDA

View Full Version : HELP! Pending Orders NOT showing up in Orders



scottct1
10-11-2011, 04:17 PM
I am having a strange issue... we recently moved to a new server...

Since the move everything appears to be working correctly, however when we get an order it shows up on the admin page as PENDING but when we click on the orders we do not see and of the pending orders.

By going through our email we can enter in the order number for the orders and see and process the order fine.

The number of orders PENDING shown on the main admin screen is correct, however the issue in the ORDERS screen these orders are not ever seen... unless we key in the order numbers by hand.

Any ideas?

michael_s
10-13-2011, 05:18 PM
Did you perhaps delete and re-enter this order status?

Is it happening for new orders or only for previously made orders?

Usually when orders are not being shown in the listing, it is because the actual order status has a different id number in the order table than it does in the order_status table. The mismatch causes them to not be shown. This usually only happens if the original order status was deleted and then re-entered in the Order Status section of osCmax, but it usually only affects orders already in the database. New orders would be shown because the order status ID matches.

Anyway, if this sounds close (or not) let me know.

scottct1
10-13-2011, 05:40 PM
Nope not it...

BTW This is on 2.0.25 I posted in the wrong area (sorry)

Again its showing up in PENDING, click on pending and you have no orders. If I enter the order numbers from the emails the I can see them

Another thing a customer noticed is when they order after the order is done if they go to their order history it is not displayed there.

Its very strange. I wish there was an upgrade utility for the new package as I would try upgrading to the new software and hope that the problem goes away.

Marotta1
11-14-2011, 04:55 PM
I seem to be having a similar problem. My Paypal IPN orders show in the sidebar as pending, but they do not actually show in the orders section in admin. I have to go into the database to see them.

What exactly do you mean by having a different id number in the order table than it does in the order_status table?

How can this be resolved? I'm on 2.0.25 as well.

michael_s
11-15-2011, 01:45 PM
I seem to be having a similar problem. My Paypal IPN orders show in the sidebar as pending, but they do not actually show in the orders section in admin. I have to go into the database to see them.

What exactly do you mean by having a different id number in the order table than it does in the order_status table?

How can this be resolved? I'm on 2.0.25 as well.

Look at the order status table contents. See what the ID number of the Pending order status is. Note it.

Then look at the Order table and note what the order_status id number is for one of the orders that is not showing. Does it match the ID number you got from the orders_status table? If it matches, then this is not your problem,

If it doesn't match, this is your problem. You need to change them (order status ID) to match and be the same number for the Pending status.

Marotta1
11-16-2011, 07:08 AM
Thanks Michael. There were 2 orders that did this. The strange thing is, one of the orders_status is listed as 1 which is Pending and one is listed as 100001 which is Preparing Paypal IPN. Niether one showed up in the orders list. The one that shows in the database as order_status 1 was actually paid through Paypal, while the other order was a Paypal order where no payment was actually sent.

It seems to me the problem lies somewhere else. So far I've only seen it happen with Paypal orders. This was a store I recently upgraded from oscmax RC3 to 2.0.25.

Any other suggestions as to what I should be looking for to remedy this?

michael_s
11-16-2011, 08:10 AM
The problem is that the order statuses changed from RC3 to 2.0.25 and you need to manually match them to your existing structure.

So, find out what the correct ID #'s should be, then either match your orders table to it, or change your orders_status table to match your orders table. The problem is just that the orders_status is not being properly set somewhere (the Paypal Module will set the order status to whatever you tell it to, so make sure it agrees with your order status table). Also, the downloads section of the admin will set an order status as well, make sure that matches your orders_status IDs as well.

Upgrades can be a little tricky since the ID's of the orders_status table are different as versions upgrade, and if you also added custom order statuses, that further complicates things.

I have seen this in a couple of my upgrades, and the easiest thing to do is to change the order status table to match the bulk of your order status ID's in the orders table, then any orders that are still not showing up, run a query on the orders table to replace the incorrect order_id with whatever id you need.

Bottom line - just make sure your new orders get set to the correct ID numbers and you will clear this up.