PDA

View Full Version : checkout problem



wowsaver
02-25-2010, 02:43 PM
osCMax version 2.0.15
url self-defense-tools.com
Paypal module:Credit/Debit Card (via PayPal) PayPal IPN v2.4
The only Payment module installed.
Enable PayPal IPN Module
True
Gateway Server
Testing
E-Mail Address
my sandbox biz email
Sort order of display.
0
Transaction Currency
Only USD
Payment Zone
--none--
Set Preparing Order Status
Preparing [PayPal IPN]
Set PayPal Acknowledged Order Status
Processing [PayPal IPN OK]
Set PayPal Completed Order Status
Processing [PayPal Complete]
Transaction Type
Aggregate
Move tax to total amount
True

Page Style
SDT ( i have this also set up in sandbox)

Debug E-Mail Address
[email protected]

cURL Proxy server

Enable Encrypted Web Payments
False
Your Private Key

Your Public Certificate

PayPals Public Certificate

Your PayPal Public Certificate ID

Working Directory

OpenSSL Location
/usr/bin/openssl

Shipping Module: United Parcel Service (XML) in test mode.

Localization order status:
Processing VV
Delivered VV
Preparing [PayPal IPN] VX
Preparing [PayPal Standard] XX
Processing [PayPal IPN OK] XX
Processing [PayPal Complete]VX
I have followed the setup as per wiki http://wiki.oscdox.com/paypal_ipn

Two problems:
1. the paypal page shows only the shipping amount but no reference to the product description or amount.
2. when clicking the back button the shipping amount changes from $7.95 to $7.00

I have no shipping set up in my sandbox biz account.

I know i am overlooking something, but i just don't see what.
Any help is highly appreciated!

wowsaver
02-26-2010, 10:08 AM
here is some additional info.
I went and took a look in the database

wen i went to the point as a customer where i get to the paypal page,
a query of the orders_total does show the shipping and the final value

A query of the customers_basket for this customer shows NULL as the final price

stewartm
06-07-2010, 04:19 AM
Hi,

With regards to the shipping rate changing, I can confirm that this problem can be resolved by moving to per item rather than aggregate in the settings. This thread (http://www.oscmax.com/forums/table-rate/22878-shipping-rates-changing.html#post54932)in the Table rates section may help.

Thanks

Stewart

pushomikuor
06-28-2010, 01:03 AM
Hi,

With regards to the shipping rate changing, I can confirm that this problem can be resolved by moving to per item rather than aggregate in the settings. This thread (http://www.oscmax.com/forums/table-rate/22878-shipping-rates-changing.html#post54932)in the Table rates section may help.

Thanks

Stewart

Thanks for the tip. Much appreciated! :)

stewartm
08-26-2010, 02:12 AM
Hi pushomikuor,

Can you confirm that changing these settings worked OK for you without any side effects?

Thanks

fourmat
09-14-2010, 08:00 AM
I can confirm that this does work for preventing the shipping rate changes, BUT I can also confirm that this messes up the usage of coupons in the store. If you don't want to use coupons, then you are good to go, other wise, I am still looking for a solution.

I have been battling this issue for a long time.

stewartm
04-14-2011, 11:43 AM
Looks like a solution has been found see 0000607: shipping costs mangled - osCmax Bug Tracking System (http://bugtrack.oscmax.com/view.php?id=607)