PDA

View Full Version : PayPal Payments Pro (UK) looping back to Delivery Info Page



Bones
07-02-2009, 01:47 AM
I'm using PayPal Payments Pro (UK) Direct Payments, and after entering cc details and hitting "Confirm Order", I am taken straight back to the Delivery Information page. The order and payment are not taken and no error messages are shown.

The environment is "Live". I have tried turning on Express Payments, but it makes no difference. Website Payments Standard is also installed and appears to be working.

The module settings are:
Vendor: The merchant ID from PayPal
User: Same as Vendor
Password: As supplied by PayPal API
Partner: PayPalUK
Transaction Server: Live
Transaction Method: Sale
Payment Zone: UK
Set Order Status: default
Sort order of display: 1
cURL Program Location: /usr/bin/curl

Pleeeeeeese help :confused:

Flagonslayer
07-02-2009, 04:36 AM
This seems similar to the issue I am having in http://www.oscmax.com/forums/paypal/19352-cant-reach-checkout_success-please-help.html#post45769. I try to confirm the order, I am transferred to the Paypal sandbox, payment takes place, and then I go back to the delivery information page. Same thing happens when I just try to use the check/money order module.. orders never complete, shopping cart never empties. I am using sandbox payments rather than live ones - Bones, did yours work on sandbox before you went live?

It's especially bad with Paypal for me, because the sandbox payments are happening (IPN's not working, but that's another story) and the customer keeps getting asked to pay for the same item. Fortunately, Paypal seems to recognize the order's the same when the cart stays the same, and won't take duplicate payment, but still, a transaction like that wouldn't inspire any confidence.

pgmarshall
07-03-2009, 01:46 AM
Post the url of your store so we can have a look.

Regards,

Bones
07-03-2009, 01:48 AM
Link to store (http://www.woodbridgebag.co.uk/index.php?tplDir=woodbridge)

pgmarshall
07-03-2009, 01:53 AM
Bones,

Do any of your products have any stock? They all say "Out of Stock" which may be a reason why you can not checkout.

Regards,

Bones
07-03-2009, 02:00 AM
There is a product in the "Test Products" category with has stock.

pgmarshall
07-03-2009, 02:25 AM
Bones,

I can see the issue ...

Your PayPal (including Credit Cards and Debit Cards) seems to work.

But the other one bounces you back to Delivery.

Which payment modules have you installed to get the Credit or Debit Card (Processed securely by PayPal) bit?

Is it these two?
PayPal Website Payments Pro (UK) Direct Payments
PayPal Website Payments Pro (UK) Express Payments

I will try and replicate in my test store and see if I get a similar result.

Regards,

Bones
07-03-2009, 03:30 AM
Bones,
Is it these two?
PayPal Website Payments Pro (UK) Direct Payments
PayPal Website Payments Pro (UK) Express Payments


Yes, it is. Thanks.

pgmarshall
07-03-2009, 07:32 AM
Bones,

I can't replicate your issue.

Have you modified the checkout pages?

Regards,

michael_s
07-03-2009, 08:54 AM
Do you have your API information correctly configured in the module? That can cause looping...

Flagonslayer
07-03-2009, 09:53 AM
I am having a very similar problem with the

Check/Money Order
Paypal Website Payments Standard
Credit/Debit Card (via Paypal)

modules. They all loop continually back to the Payment Information page after attempting to confirm the orders. The carts never empty, and the customer is prompted basically to pay again (the Paypal end of it seems to be working, at least in the sandbox - haven't tested it Live yet).

michael_s
07-03-2009, 09:56 AM
Check/Money Order
Paypal Website Payments Standard
Credit/Debit Card (via Paypal)

modules. They all loop continually back to the Payment Information page after attempting to confirm the orders. The carts never empty, and the customer is prompted basically to pay again (the Paypal end of it seems to be working, at least in the sandbox - haven't tested it Live yet).

Sounds like you have something wrong with your install. What version of osCMax do you have installed?

Flagonslayer
07-03-2009, 10:59 AM
I am using version 2.0.2. I've modified it very little, implementing only one fix I found in the forum to correct a fatal error I ran into early on. I didn't document the fix I used, but I think it had to do with session durations.

Bones
07-06-2009, 12:24 AM
Have you modified the checkout pages?

No, and I've just tried it running the "Fallback" template through template switching, and it does exactly the same.

I'm using OSCMax v2.0.2

I have configured PayPal Website Payments Pro (UK) Direct Payments and
PayPal Website Payments Pro (UK) Express Checkout as described earlier in the thread. Do I need to configure Credit/Debit Card (via PayPal) or any other modules?

Thanks

Bones
07-08-2009, 12:43 AM
Can anyone shed any light on this. It's the final hurdle to getting my store up and running. HELP. PLEASE!

Bones
07-14-2009, 03:47 AM
I still haven't solved this, but wanted to post an update on where I am with it.

I have done a clean installation on my computer (with MAMP) and added the theme and the same PayPal info as on the online site. This works!
I have overwritten the online files with the offline ones. This makes no difference.
I have disabled the SSL on the online site (it's not enabled on the local site). This makes no difference.
I have ensured that the same UK-Counties SQL file is uploaded to both. This makes no difference.
I have continued to apologies to my poor customer who wanted their site up and running months ago.


What can I have missed?