PDA

View Full Version : change path to images to absolute reference



mkraft
12-31-2003, 06:36 PM
My web host uses IIS. They do not permit file uploads to folders inside the main website folder. I can create a new folder on the same level as the main folder for my images, but I need a little help in modifying the code to display the images in the pages and to direct the upload to the folder.

Any tips?

jpf
01-05-2004, 09:07 AM
Not sure what your saying - you can not have subfolders in subfolders?

Where did you install OSC - where did you need to put the images. I have an IIS server and works fine.

If you installed to www.mystore.com/catalog/ and want the images from www.mystore.com/images/ then change your configure.php file and change the define for images to "../images" do the same for upload/downloads.

Better suggestion - get a Apache host.

Anonymous
01-09-2004, 06:49 AM
Ok - I have some of this figured out, so let me restate the situation:

In IIS, my images are in a folder not inside the root web, but at the same level (ISP security stuff). The created a virutal directory for me called maximages. I made the apporpriate changes in the catalog/includes/configure.php, moved my images, etc. and that part works.

In the admin, though, I've tracked my problem down to the DIR_FS_CATALOG_IMAGES variable. I keep getting an error that the folder for the images doesn't exist. I've tried putting the fully qualified path (d:/hosted web sites/my.id/site/maximages/), just "/maximages/", and just about any other combo I can think of, but I am still getting the error (with the missing folder error changing to reflect whatever I set the variable to). I guess if somebody can tell me how this var is used in the code, or where it is, I can figure out how I need to config that variable so it works.

Thanks in advance!

jpf
01-09-2004, 06:53 AM
Have you tried 'maximages/' (not '/maximages/') or '../maximages/' ?

Anonymous
03-06-2004, 07:01 AM
there are 2 config.php files, one is in the includes and one is in includes admin

Anonymous
04-24-2004, 01:17 AM
Did you ever figure out this problem? I have the same "images directory does not exist".