View Full Version : Authorize.net SIM

11-07-2003, 11:04 PM
I am driving myself crazy with this... Is there anyway to get the MS MAX install to use the SIM function for Authorize.net? I really need to figure out a way and have gotten no where. I tried the contribution from the osc site but it gives me errors? I have MS2-MAX V1.5 install. Thank you for any help!

11-08-2003, 09:44 AM
1.5 already has AIM built in. Why bother with SIM?

11-08-2003, 02:45 PM
Thank you for the reply. I do not have an SSL cert on the server yet and was going to run SIM for now until I get a Cert installed.

There is not much help on getting the SIM to work so I think I will go ahead and get the SSL cert and try the AIM since it seems to be the better choice.

Any tips or things to look out for if using AIM?

11-08-2003, 08:09 PM
When using AIM, make sure you do not have any of the SIM settings still residing in your Authorize NET account. This wll mess things up. Delete any return urls that you set, and remove any other settings related to SIM.

Also, make sure you generate a KEY to be used in the osCommerce module from the admin when you are setting it up.

One other thing, Require Password should be OFF.

Good luck to you.

11-08-2003, 10:16 PM
Alright I installed the Cert and am trying to get AIM to work. This process has been a nightmare to get running so far, I must be missing something.

At Authorize.net

I deleted the return URLs
Am in test mode.
Took out any rejections relating to AVS (I thought this could be the problem?)
Password-Required Mode is unchecked.

The account is in test mode.
In the Admin I have the user name and transaction key.
In Admin I have the account set to test mode.
I have messed with different configurations of the sessions. Right now I have Check SSL Session ID true and Check for Spider set to true and all others false.

The shop switches to secure without any problems (Yeah!)

I am still yet not able to process the test aco****. I get an error stating:

There has been an error processing your credit card. Please try again.

No matter what I do I can not get this to work. Any other tips, I have never had so many problems trying to get something to work?

11-09-2003, 01:10 AM
This is most likely related to cURL. Check to see if is compiled into PHP. It needs to be.

11-10-2003, 07:38 PM
Sorry for the late reply back. That was the exact problem, thank you so much!!

I installed Curl (which ended up with Apache completely needing reconfigured beause of an error in CPanel grrrr). Anyway, 30 hours later I have it installed.

I have no idea what to do now though? I have not installed the direct mod yet. I was reading and it said to shell into server and check the location of curl.

When I put in /usr/bin/curl -v it returns:
curl: No URL specified!

I am assuming somewhere I need to add the URL for curl? Any tips on how to do this?

Also when I put in whereis curl the following is returned:

curl: /usr/bin/curl /usr/ /usr/includes/local /usr/man/man1/curl.1 /usr/man/man1/curl.1

Any tips on how to procede? Thanks for all your help!!

11-10-2003, 11:01 PM
Did you recompile PHP with curl? That looks like the problem. You need to comiple curl support right into php. You can do this with buildapache/easyapache option 6.

You can check if it is compiled in by running the server info script included in the osCommerce tools in the admin. Look for something like this in the curl section:

CURL support enabled
CURL Information libcurl/7.10.5 OpenSSL/0.9.6b zlib/1.1.4

If you don't see that, then you don't have curl compiled into php and you will have to do a recompile.

11-11-2003, 05:53 AM
Hi, my mistake about the curl, it is installed, I was checking the wrong way. Here is from the tools section:

CURL support enabled
CURL Information libcurl/7.10.5 zlib/1.1.4

This is somewhat different than what you had posted. When compiling PHP I choose Curl Curl with SSL and OpenSSl as the options and everything installed.

Do I need to make any changes to the actual files? It is installed in /usr/bin/curl so the path did not need changed. I noticed in the one contribution at oscommerce it required to put in the Authorize.net passord into the file but the Max install does not use this contribution. For some reason with just a plain install it is not working because I get the same error as before. I still have the require password unchecked at Authorize.net. Any advice?

11-11-2003, 07:57 AM
doggifts, that is what I meant by option 6 (Curl + Curl + SSL and Open SSL). Sorry I wasnt more specific.

You need to generate your transaction key at AuthorizeNet and paste that into the module.

As another option, try this:

Comment out the line in authorizenet_direct.php that says:

exec("/usr.bin/curl -d \"$data\" https://secure.authorize.net/gateway/transact.dll", $response);

and immediately after it add this:

$url = "https://secure.authorize.net/gateway/transact.dll";
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL,$url);
curl_setopt($ch, CURLOPT_VERBOSE, 0);
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);
curl_setopt($ch, CURLOPT_RETURNTRANSFER,1);
$authorize = curl_exec($ch);
curl_close ($ch);
$response = split("\,", $authorize);

Let me know if it works for you.

If not, the problem is most likely your settings at AuthorizeNet.

11-11-2003, 08:59 AM
msasek, thank you for all of your help so far! I really appreciate it.

When you say paste the transaction key into the mod, do you mean in the admin section or do I need to paste it in one of the actual files? I have it in the Admin section but not the actual files, I thought it would pull the info from the database.

I tried the new code to add to authorizenet_direct.php and it still comes up with the same error when trying to process.

Here are my AuthorizeNet settings:

Transaction Submission
Virtual Terminal - Have not changed anything in this from default setup

Payment Form - Fields (I have tried different combinations of this but here is current)
Customer Billing Information
(All Options selected set to View Only)
First Name
Last Name
Zip Code
Customer ID

Shipping Information
(All Options selected set to View Only)
First Name
Last Name
Zip Code

Additional Information
Nothing selected

Require Password for ALL Transactions
Require Password for ALL Transactions - Unchecked

Upload Transaction Files (Not sure what to choose for file seperator Encapsulation)
Email Customer - Yes
Apply AVS Filter - No
Apply Card Code Filter - No
Default Field Separator - comma
Field Encapsulation Character - double quotes

Field Inclusion and Order (This May be the problem, not sure what is included?)
Payment Method
Transaction Type
Authorization Code
Transaction ID
Credit Card Number
Credit Card Expiration Date
Bank Account Number
Bank Account Number
Bank Account Type
Bank ABA Routing Code
Bank Name
Customer ID
Customer First Name
Customer Last Name
Customer Company
Customer Address
Customer City
Customer State
Customer Zip
Customer Phone
Customer Fax
Customer Email
Exclude - 49

WebLink (not sure about this one either?)
Are Your sure you want to enable weblink? The submit button says yes

Transaction Response

Transaction Version - Current Version: 3.1

Response/Receipt URLs - Blank

Silent Post URL - Blank

Email Receipts (I should add something here? This gets sent to customer?)
Enable Email Confirmation - Checked
Configure Email Message - Blank without text

Receipt Page - Receipt Method - blank, no URL

Relay Response - Blank

Direct Response (Should it be delimited?)
Delimited Response - No
Default Field Separator - comma
Field Encapsulation Character - Blank

Card Code Verification - N and P selected

FraudScreen.Net Enabled: - No

Address Verification - Changed to all unchecked (any tips on good settings for this?)

MD5 Hash - Blank

Test Mode - This account is currently in TEST MODE

For the oscommerce admin settings I have:
Username - populated
Transaction Key - populated
Transaction Mode - TEST
Transaction Method - Credit Card
Customer Notifications - False (should I change this to true since the AuthorizeNet is True?)
Merchant Notifications - True

The test number I have been using are below:
5424000000000015 MasterCard
4007000000027 Visa

Sorry for such a long post, I thought it would be the best way to show everything setup and easiest for you to read. Again thank you so much for your help, you have been great!

11-11-2003, 11:21 AM
This may be the problem:

Delimited Resonse - No
Default Field Separator - comma
Field Encapsulation Character - double quotes

Change the following:
Delimited response should be - YES
The Field Encapsulation Character should be blank.

Good luck... my fingers are crossed... :)

11-11-2003, 12:32 PM
Half way there, I think? That seems to take care of some of the problem, thank you so much!

It still comes back with the same error when I try to process the Max build?

I also have a install of osCommerce 2.2-MS2 without any mods that I have been using for testing. When I try to process using this it goes through without the error. The only problems are when I click continue at the last page where it asks if you would like to keep up to date on the products just ordered it returns a page not found error?

Also, this order shows up under the order total for customers but does not show up in the AuthorizeNet system as it still shows no orders? Is this normal not to post anyhting in test mode?

Any ideas of where to go from here as now I am really stumped?

11-11-2003, 12:33 PM
Forgot to mention, should I upgrade the authorize_direct mod to the latest version (1.3)? I noticed my build is 1.2.

11-11-2003, 12:49 PM
The version in MAX should work without any upgrades. I am using it on several hundred sites without a problem. Test mode will not post any data to ANET that you can look at.

If it is working on one and not the other, why not copy the files over from the working install and give it a whirl... something is different in there. :)

11-11-2003, 12:53 PM
Diregard the redirect not working on the osCommerce 2.2-MS2 build. It was the config file not setup correctly.

I still can not figure out why the Max build keeps giving me an error and why it did not post to AuthorizeNet? Could the CVV be an issue?

In the osCommerce 2.2-MS2 build when I click continue after the confirmation it instantly goes to the secure authorizenet dll page. When I try it on the Max build it instantly goes to the checkout_process page?

11-11-2003, 01:20 PM
The main difference is that the osCommerce 2.2-MS2 build that is working does not have the AuthorizeNet Mod and authorizenet_direct.php file. It is the standard install from osCommerce.

I will need to copy the checkout_process.php and authorizenet.php files from the test and delete the authorizenet_direct.php file. This would cause me to lose the ability to have the CVV info. Would it cause any other problems?

11-11-2003, 02:12 PM
I did what I descibed above. Copied the files /includes/modules/payment/authorizenet.php and /checkout_process.php from the osCommerce 2.2-MS2 that does not use the Direct mod.

When doing this I now get the following error on the Max build:

99 - This transaction cannot be accepted.

Any ideas?

11-11-2003, 08:00 PM
Guest, revert back. The 2 modules are totally different, and not compatible.

One uses SIM and one uses AIM (ms2-max)

11-14-2003, 09:41 AM
Sorry so late getting back to you. I see what you mean by they do not work together.

Some of the db names had been changed and it was missing a few. I revbuilt the config database and added the orginal install files and am going to use the SIM. It is all working now. Thank you so much for your help!!