Results 1 to 2 of 2

Thread: Easypopulate stalls - claims duplicate Product ID (solved??)

  1. #1
    Active Member
    Easypopulate stalls - claims duplicate Product ID (solved??)


    Join Date
    Sep 2009
    Location
    Vancouver, BC, Canada
    Posts
    444
    Total Contributions For

    JRR     $ 180.00
    Rep Power
    62


    Default Easypopulate stalls - claims duplicate Product ID (solved??)

    I haven't played with EP for a while, and, thanks to Ridexbuilder, I thought I would take a look at using it again to load up a number of new products to the site. However a problem arose after extracting the current listing from my live site and then trying to copy it to my localhost site using Easypopulate 2.76i-MS2 (called EP from now on). I kept getting an error at a specific product where EP stopped and complained about a duplicate product key "1062 - Duplicate entry '####' for key 'PRIMARY'" . ('####' being a particular number) So I checked the CSV file, nope, no duplicate of that number there, then I went to the database, and again no actual duplicates in the data file product_id number, then did a bunch of scanning online for suggestions - no joy.

    Tired and a bit frustrated I then, as an experiment, deleted that product_id column - and then I found I could upload the EP file copy of my live site to my localhost version as expected!

    OK, that was interesting, now what happens if I restore the product_id column to the EP CSV file and try uploading it again? Curious - now the upload works correctly WITH the original product_id column.

    I have no idea why that 'fixed' the problem, but perhaps it will help someone else if they run across something similar.

    John :-#)#

    PS, just tried doing that again with an EP CSV file from a different day - new error number, same error style, deleted product_id, ran EP Upload and Import EP file (Normal), inserted all products, then restored product_id to same file, ran EP insert again, and now it ran to completion as above with the same product_id column as before...
    Last edited by JRR; 11-09-2017 at 11:37 PM.

  2. #2
    osCMax Development Team

    Easypopulate stalls - claims duplicate Product ID (solved??)

    ridexbuilder's Avatar
    Join Date
    Jul 2008
    Location
    Haggisland
    Posts
    4,062
    Total Contributions For

    ridexbuilder     $ 15.00
    Rep Power
    94


    Default Re: Easypopulate stalls - claims duplicate Product ID (solved??)

    Hmm, a bit of a torrid time!
    You MUST have unique product models for products, even if they are just your own made-up internal codes. Try to keep them simple with no apostrophes, or similar.
    It you don't then it's best to export the product table and add them with a spreadsheet, followed by reimporting them.
    See attachment for a customised EP.
    Attached Files Attached Files
    Last edited by ridexbuilder; 11-12-2017 at 03:45 AM.

    Developers resource at bitbucket
    *** *** ***
    oscmax.co.uk / ejsolutions.co.uk
    Hosting plans with installation, configuration, contributions, support and maintenance.
    *** FREE osCmax hosting available ***
    oscmaxtemplates.com

Similar Threads

  1. EasyPopulate and product images.
    By DanDan in forum Bugs and Problems
    Replies: 2
    Last Post: 05-08-2012, 10:50 AM
  2. [Catalog Issue] Bug no #0000702 Not solved to me :|
    By freeman78 in forum Bugs and Problems
    Replies: 3
    Last Post: 08-06-2011, 12:56 PM
  3. Checkout stalls at blank page on checkout_process.php
    By hollowgram in forum osCmax v2 Installation issues
    Replies: 23
    Last Post: 08-13-2010, 11:45 AM
  4. Adding product attributes with easypopulate
    By mcg1103 in forum osCommerce 2.2 Modification Help
    Replies: 2
    Last Post: 08-20-2003, 11:00 AM
  5. Installation Stalls
    By ramonjaime in forum osCommerce 2.2 Installation Help
    Replies: 1
    Last Post: 11-13-2002, 07:57 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •