Page 5 of 5 First ... 345
Results 41 to 46 of 46

Thread: Who's Online 3.4 ~ OSCMax

  1. #41
    wkdwich
    Guest


    Default Re: Who's Online 3.4 ~ OSCMax

    OK I really need help on this one please.. I just checked the admin/whos_online.php again on cart 1 and the page came up, showed no one online.. had a friend go to the cart and refreshed and blank page again..

    I now checked admin/whos_online.php in cart 2 - it also came up, showed no one online, I had him now go to this cart, refreshed and whamo blank page again

    I have compared:
    admin/whos_online.php
    admin/includes/functions/general.php
    admin/includes/functions/whos_online.php
    admin/includes/application_top.php

    All are identical..

    what now????

  2. #42
    wkdwich
    Guest


    Default Re: Who's Online 3.4 ~ OSCMax

    is no one else having an issue with a blank whos_online page?? Just installed (upgraded really not new install) to latest version, and once again I have this blank page issue.. I have checked the logs and nothing is showing up there at all

    I will tell you the admin/whos_online file I am using has not be tweaked in any way shape or form from the original

  3. #43
    JohnW
    Guest


    Default Re: Who's Online 3.4 ~ OSCMax

    You can put something like this in application_top or probably in the file itself it you like.

    error_reporting(E_ALL);
    ini_set('error_log', DIR_WS_INCLUDES . 'wkdwich_errors.log');

    Or, however you want to do it, but you can get some errors this way.

    Check all your permissions that are involved in case one is set incorrectly that can give you a 500 error.

    Or, phpsuhosin may be preventing it from running.

  4. #44
    wkdwich
    Guest


    Default Re: Who's Online 3.4 ~ OSCMax

    ok got something to work with now.. I put that set of lines directly in whos_online.php

    Code:
    Fatal error: Cannot instantiate non-existent class: simplexmlelement in /home/wkdwich/public_html/shoppeNEW/admin/whos_online.php on line 109
    Lines 106-110
    Code:
      $answer = new SimpleXMLElement($backup);
      if (!$backup) return false; // Failed to open connection
     }else{
      $answer = new SimpleXMLElement($d);
     }
    I thought the fact I had not changed permission on the backup folder might be the answer, but no that wasn't it.

    I tried various combinations of commenting out those lines, changing it to:

    Code:
      // $answer = new SimpleXMLElement($backup);
    //  if (!$backup) return false; // Failed to open connection
    // }else{
    //  $answer = new SimpleXMLElement($d);
    }
    Did bring up the page but with left navigation and the content itself had a slew of other errors..

    I searched the forums here and at oscommerce.com and found this post:
    Who's Online Enhancement 1.4 - osCommerce Community Support Forums - Page 79

    unfortuantely that again gave me the page, left navigation & content but with a whole slew of errors..

    FYI I do not have suhosin installed
    running PHP Version 4.4.7

    Further in the same thread:
    Code:
    If you are still getting this error there is a fix that was posted but was not correct in how to comment it out.
     
    The correct way is to do this..
     
    //$answer = new SimpleXMLElement($backup);
    //if (!$backup) return false; // Failed to open connection
    }//else{
    //$answer = new SimpleXMLElement($d);
    //}
     
    Notice the line }//else{ If you put the // in front of the } you will get another error.
    but that did not work either, page comes up, but same slew of errors in the left nav and content..

    where do I go from here???

    I forgot to add that in admin/functions/whos_online.php I added:
    Code:
    if(!function_exists('stripos')) {
    function stripos($haystack, $needle, $offset = 0) {
    return strpos(strtolower($haystack), strtolower($needle), $offset);
    }
    }
    as was instructed in the thread @ forums.oscommerce.com

    Thats when I started to get the page displaying but with loads of other errors
    Last edited by wkdwich; 06-18-2010 at 07:03 AM. Reason: added comment

  5. #45
    JohnW
    Guest


    Default Re: Who's Online 3.4 ~ OSCMax

    Why are you still using php 4??????????????

    The SimpleXML extension requires PHP 5.

    I'm not sure if you realize it or not but the blank screen is an error but if you aren't printing the errors to the screen then you can't see them, which is good because printing errors to the screen gives hackers information. You should set up a test site that is password protect by Apache to help troubleshoot problems.

    Get PHP 5+
    Last edited by JohnW; 06-18-2010 at 09:48 AM.

  6. #46
    wkdwich
    Guest


    Default Re: Who's Online 3.4 ~ OSCMax

    Quote Originally Posted by JohnW View Post
    Why are you still using php 4??????????????

    The SimpleXML extension requires PHP 5.

    I'm not sure if you realize it or not but the blank screen is an error but if you aren't printing the errors to the screen then you can't see them, which is good because printing errors to the screen gives hackers information. You should set up a test site that is password protect by Apache to help troubleshoot problems.

    Get PHP 5+
    Yes I am aware the blank screen is screaming at me ERROR BUZZ BUZZ ERROR

    My issue was the variety of php apps running on the server. I have now set up a test site at a free hosting place and was able to test many of the other apps to see if they rill break or not on php5.. good news is 90% will not break, the remaining either I could not get the settings right at 4a to test or they flat out refused to corporate.. so I will be upgrading ASAP..

    For the time being though I did just upload the old whos_opnline.php and at least it gave me some info there..

Page 5 of 5 First ... 345

Similar Threads

  1. Online osCMax sandpit
    By MindSpace in forum General Topics & Chit Chat
    Replies: 1
    Last Post: 01-31-2008, 08:13 AM
  2. Who's Online Enhancement
    By michael_s in forum New osCommerce Contributions
    Replies: 0
    Last Post: 01-30-2008, 07:21 AM
  3. Who's Online Enhancement
    By michael_s in forum New osCommerce Contributions
    Replies: 0
    Last Post: 12-03-2007, 09:21 AM
  4. Who's Online Enhancement 3.21 - For OSCMAX
    By ALElder in forum osCmax v2 Customization/Mods
    Replies: 2
    Last Post: 08-02-2007, 11:32 AM
  5. online new v.1
    By michael_s in forum New osCommerce Contributions
    Replies: 0
    Last Post: 03-09-2007, 06:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •