PDA

View Full Version : New Payment Module Problem to osCMax v2



cameroti
10-17-2005, 06:28 AM
Hi,

First up, great job with osCMax. The work that has been done is fantastic and the support much appreciated - thanks Michael & jpf.

I have just installed a new payment module to osCMax RC2 from the oscommerce contributions:

http://www.oscommerce.com/community/contributions,306

It is a straight forward module that allows details for a direct bank deposit to be displayed at checkout as a payment option. It has installed successfully from Admin, but does not show up during checkout. Is there some further configuration required when using payment modules with osCMax RC2?

Any help appreciated.

Cheers
Tim

jpf
10-17-2005, 06:48 AM
Check your SORT ORDER for this module in admin (should be maybe in the 200-300 range)

Good Luck

cameroti
10-17-2005, 03:02 PM
Hi,

Well spent some time playing around with various sort order combinations and removing / re-installing modules to see if i could get them to work. Thanks for the tip on using values between 200 and 300, but despite using a variety of combinations, I could not get them to work.

To recap, I have four payment modules:

COD
Check/Money Order
Credit Card
Bank Deposit

The first three are vanilla osCMax.

Interestingly, the COD no longer works, despite working just fine post installation. The Check/Money Order and Credit Card work just fine. They can be turned off / on, have their order changed at will (using any value from 0 to 300 etc). The COD and Bank Deposit modules have installed just fine, but wont display when set to true. I do not have any zones set up.

I noticed someone else had a post on COD not working with RC2. Michael had suggested turning off Check/Money Order and Credit Card and setting COD to sort order 1. I give this a whirl with no success. I posted this particular result to that thread (Apologies if this is a double up).

Where to from here I am not sure, but I thought I would get this down in case others are experiencing the same problem.

Any ideas much appreciated.

Cheers
Tim

cameroti
10-17-2005, 08:38 PM
Hi,
Just thought I would note that the COD payment module not working is getting some discussion at the following link - two issues are related? Any ideas appreciated.

http://www.oscdox.com/PNphpBB2-viewtopic-t-5484.html

Cheers
Tim

cameroti
10-19-2005, 06:25 AM
Have tried to install another module with no success. I can't see any reason why payment modules that work in MS2 won't work with oscMax RC2? Anyone able to put me on the right track?

Thanks
Tim

cameroti
10-20-2005, 04:49 AM
Have resolved that this module is not displaying as it contains a default to not display if the cart contains virtual products. For some reason my installation defaults to assigning content_type virtual to all my loaded products. This is a separate issue! The loaded module works fine for products that are not virtual.

THanks for those that helped.

Cheers
Tim

michael_s
10-20-2005, 08:00 AM
If you create a product with zero weight or undefined weight, it is a virtual product.