PDA

View Full Version : PWA problem or feature? Please help!



giyer
10-19-2004, 06:14 AM
Hi,

I am using MAX1.7 with the PWA contribution installed. This is a good option for some of my (expected!) customers.

Oddly, the system DOES store the details of the PWA customer also..I noticed that if I went back and entered my e-mail address (as required by the PWA module), it reports that the e-mail already exists!

When I checked the Customers under Admin, I see that there are accounts for every PWA test customer I created.

This is kind of opposite of what is said at the time the user chooses the PWA option and I quote "Proceed to Checkout without creating an account. By choosing this option none of your user information will be kept in our records, and you will not be able to review your order status, nor keep track of your previous orders."

I am using the AABOX template (the only one where PWA shows up).

Is this the right behavior of the PWA module? Or is something wrong with my setup? I have not modified anything in the MAX1.7 install.

Please Help!
TIA
G

pedrump
10-19-2004, 09:59 PM
this is the right behavior the PWA contribution. It's basically a hack around the account system of oscommerce. the users are creating accounts, but without passwords so they can never log in.
you'll note the page in which the user enters their info is similar to the edit customer page in the admin.

I agree, it is opposite of what the pwa text says.

giyer
10-20-2004, 08:04 AM
Thanks Pedrump!
I have no problems with the accounts getting created! The only problem is that when the same guy decides to buy again there is a Major Error Display - email already in the system!!!!
It would be nice if the PWA process cleaned up after the order is processed.
Once I am done with the initial setup may be I will work on this! But at this time, I would like to know how others are using this? May be they are losing customers who may be repeat but don't want to register and are turned off by the "e-mail in the system" message.
TIA
G