PDA

View Full Version : Problem with language



ukkoc
03-17-2012, 04:34 AM
I've install osCmax on my host and I'm now online. I have a problem with my language charset only in a mailling.
I use Turkish language. On website or administrator site have not problem with language. My problem is only in e-mail.

If customer create a new account then recieve an e-mail but the Turkish characters (only this Ş,İ,Ğ,ş,ı,ğ) shown unknown characters.
What must I do to correct this problem?

Today I have fix my osCmax 2.5.0 to 2.5.0-PL1 and transleted to Turkish.

define('CT_SHOW_TAX_RATE_NEAR_PRICE', 'Display tax rate near price?');
define('CD_SHOW_TAX_RATE_NEAR_PRICE', 'Some countries require you to show the tax rate included near where the price is displayed.');
define('CT_SHOW_SHIPPING_NEAR_PRICE', 'Display link to shipping charges near the price?');
define('CD_SHOW_SHIPPING_NEAR_PRICE', 'Some countries require you to display a link to your shipping charges near the price. Requires <b>Display tax rate near price</b> to be enabled.');

Really this is required of my country.
But I can't see this lines on my configuration oy my store. Why?

And newsletter dosen't work together.

ragerbua
03-17-2012, 08:57 AM
Hi ukkoc!

"Display tax rate near price" is disabled by default and has to be switched on in admin panel. The settings should be found in Configuration/General Settings/My Store.

Please note that "Display tax rate..." works without "Display link..." but not the other way round.

pgmarshall
03-17-2012, 09:26 AM
You can not see it as it is a new function I wrote which will be released in v2.5.1 due at the end of this month.

Once you have this new version the admin setting will be available for use in Admin -> Configuration -> My Store

Regards.

ukkoc
03-18-2012, 02:28 PM
Thank you for your answer from display tax...
What can I do for the special characters? Have anyone a idea?

ukkoc
03-26-2012, 03:42 PM
this is the greating message if I created a new account.

Sayýn ümit
Hesap Detayý:
Kullanýcý Adý:um**@gmail.com
à ifre:*******
ÖZà EKER TOPTAN TELEFON maðazamýza hoþ geldiniz.
Size vereceðimiz çeþitli hizmetlerden yararlanmak için ilk adýmý attýnýz. Bu hizmetlerimizden bazýlarý;
Alýþveriþ Sepeti - Sepetinize eklediðiniz ürünler siz silmedikçe ya da satýn almadýkça kaybolmaz.
Adres Defteri - Satýn aldýðýnýz ürünleri siz istediðiniz takdirde adresiniz dýþýnda baþka adreslere de yollayabiliriz! Bu sayede özel günlerde istediðiniz kiþiye hediye yollayabilirsiniz.
Geçmiþ Sipariþler - Daha önceden yapmýþ olduðunuz alýþveriþleri istediðiniz zaman görüntüleyebilirsiniz.
Ürün Yorumlarý - Ürünler hakkýndaki fikirlerinizi paylaþabilir kullanýcýlarýmýzla paylaþabilirsiniz!
Hizmetlerimizle ilgili sorularýnýzý, lütfen bize yollayýn: siparis@ozsekertop**.com.
Not: Bu e-posta adresi müþterilerimizden birisi tarafýndan bize verilmiþtir. Eðer siz üye olmak için baþvurmadýysanýz, lütfen siparis@ozsekertop**.com'a e-posta gönderiniz.


the problem charcters are;

Ü Ş Ğ İ Ö Ç ğ ü ı ö ç ş

what must I do for corrected it?

ukkoc
04-26-2012, 02:56 PM
I have set my ../admin/includes/language/english/core.php

find:
// charset for web pages and emails
define('CHARSET', 'iso-8859-1');

changed :
// charset for web pages and emails
define('CHARSET', 'iso-8859-9');

and to latin5, utf8_turkish_ci

but my emails go wtih unknown characters.
can some body help me?

niallb
04-27-2012, 12:12 AM
Do you read your emails in another program? (I read mine in Outlook). You may need to download a language pack for your email thru them

pgmarshall
04-27-2012, 04:03 AM
You could try replacing the unknown characters with their HTML entities.

HTML ISO-8859-1 Reference (http://www.w3schools.com/tags/ref_entities.asp)

Regards

Paraskevas
05-23-2012, 03:27 AM
Hi,
i m writing from Greece. We already have an e shop with oscommerce 2.2 .
And now, just because the version is old we would like to use oscommerce max 2.5 which seems to us an excellent job.
For 30 days now. we tried everything to install the greek characters but we have made it till the checkout process.
From that point unfortunately the greek characters do not appear and instead of them some unknown characters appear.
We already have tried GR ISO 8859-7 and UTF 8 .We are most interested at UTF 8.
If there is something that you could advise us you are kindly requested to do so.
Any help will be appreciated. Thanks in advance.

pgmarshall
05-23-2012, 06:12 AM
Have you tried Admin -> Configuration -> Email Options -> Use MIME HTML when sending mails -> true

Regards.