PDA

View Full Version : OSCMax will not send emails



zippy142
01-22-2012, 06:09 AM
Newbie here,

I was running OSCommerce for several months and found OSCMax so I did a conversion. Removed, Oscommerce, Updated my Ubuntu to 11.04 and installed new OSCMax. I've started loading products into the store and tried the "Contact Us" feature. It would not send emails. I did not realize that I would need to re-setup my mail in Ubuntu after the upgrade. So I fired up Evolution Mail and put in the settings to connect to my ISP's mail server, sent a test email and it worked. I setup the email in OSCMax admin panel (checked all the stupid stuff - Send emails - true etc). I've tried all kinds of settings but to no avail. OSCMax is saying the mail is sent. I checked the Ubuntu email logs and there are empty.
I'm just about ready to go but this is a huge snag. Any help would be appreciated.

pgmarshall
01-22-2012, 09:54 AM
Can you check your PHP version and settings? Goto Admin -> Tools -> Server Info -> Then search for 'Path to sendmail'

zippy142
01-23-2012, 04:41 AM
Thanks for the incredibly fast response, I really appreciate it. The info you requested is:

PHP version 5.3.5-1 Ubuntu 7.4

Path to sendmail = /usr/bin/sendmail -t -i
I also found:
Send Mail From =none
Sendmail path = /usr/bin/sendmail -t -i

Hope this helps,

Thanks in advance

zippy142
01-23-2012, 05:50 AM
Another update.... Since you are looking at the sendmail as a problem, I went on the server and went to the /usr/bin/sendmail and I could not find it. I typed sendmail -bt at the terminal and it looks as though it is not installed! The command listed about 10 packages that would install sendmail. If this is the problem, could you suggest a package. I noticed one was named SSMTP. My ISP, Comcast uses SMTP/POP for the mail transport.
Thanks

pgmarshall
01-23-2012, 11:25 AM
Mail is not really my forte but I believe you will either need to install sendmail to the path shown OR you need to switch you mail delivery to SMTP if this is what your ISP uses. The second option is quicker and easier to check.

Edit here:

Admin -> Configuration -> Email Options -> E-Mail Transport Method -> Change this to SMTP

Give it a go and see if we get any further! If not, then you may need to ensure sendmail is on the server.

Regards.