PDA

View Full Version : Admin Session Issue



dlampkin
08-12-2011, 06:27 AM
Hi all, I've done a search on this but haven't found a problem quite like mine :D

On my laptop, regardless of admin session ID, the admin section works flawlessly. On any other machine however, any pages that have multiple functions (from what I can see it's configuration.php and modules.php) return me to the admin login screen and give me a new session ID when I attempt to access them. All of the other pages (including the non-admin pages) work fine, and log me out after ~30 mins of inactivity as expected. I haven't modified configuration.php or modules.php in any way, and my config files seem fine, since everything else works.

Any assistance would be a massive help!

michael_s
08-12-2011, 08:56 AM
I have seen this before, but it could be just about anything causing it.

Since it works on one machine and not others, check your browser settings on the machine that works, and make sure that your other machines match it. On the machines that don't work, try different browsers and if you have browsers that allow extensions (chrome, firefox) disable extensions by running in private/incognito mode to see if that solves the issue. If it does, you have narrowed it down to an extension.

If that doesn't fix the issue, look carefully at the paths/urls in your admin/includes/configure.php file and perhaps try different versions of constants to build the same path. If you are using shared ssl in the admin panel, try turning off ssl support entirely to see if that is the source of your issues.

Just basic troubleshooting until you can determine where the source of the trouble is.

dlampkin
08-12-2011, 09:17 AM
Thanks for the reply Michael. I'm using vanilla firefox 5.0 installs on both machines, and I've wiped cache/cookies/active logins on both. I've also emptied the sessions table in my database. I'm not using SSL, so I suppose that narrows it down to my config files. I'll have another attack at the them now, it could be related to a domain name change I carried out recently. Thanks for your help.