PDA

View Full Version : [Mod Installation] Installing another language other than the the pre installed



Dillion
06-18-2011, 12:15 PM
Hi ,
I have created another language pack containing all the files contained in the pre installed language folders. Re defined the core.php file. Everything shows up as it should but when I try to activate advanced actions such as click on account or add product to cart, the site produces a blank page. Everything works fine in English. When one translates by choosing by clicking on the language icon it displays the new language properly.
Your help is appreciate. I am trying to move the shop up to 2.5 as the shop is suffering from a failing payment system. I am trying hard to make this be a success but if I cannot get the language of my home market to work.

Any information that could help find a solution would be much appreciated.

Dillion

pgmarshall
06-18-2011, 01:35 PM
Have you added all the language files required for your new languages? There is a bugtracker open about the paypal_wpp.php language file which will cause a white screen if you do not add a language file for it (even if not using paypal).

0000912: PayPal WPP language issue - osCmax Bug Tracking System (http://bugtrack.oscmax.com/view.php?id=912) - there is a link back to the thread. This will be fixed before v2.5 RC2.

Wondering which languages you are releasing ... would you be willing to share ... as we are looking to extend the number of available translations for osCmax.

Regards,

Dillion
06-18-2011, 08:49 PM
Hi thanks for the reply. I did update the paypal files and the problem persisted. Anyway I checked the file encoding of the core.php and a few other files. I changed these to UTF-8
and it worked in Firefox and Safari but Chrome is still showing me your basket is empty page
when I try to add a product.
Do you know if the file encoding has such a major affect on the application?

The language pack is Swedish and when (with a little help from the god of programming) I get this working I have no problem on contributing the pack.

Thanx Dillion

pgmarshall
06-18-2011, 11:44 PM
Are you running this on a live server or developing locally on WAMP/LAMP/MAMP? If you are doing it locally - I have come across an issue which is browser specific regarding sessions dropping ... the cart is always shown empty because the browser is not holding the session.

I had this on Firefox running on MAMP (Mac) - solution: define the actual IP rather than use localhost in the configure.php files (catalog and admin).

If you are on a live server - do you have an URL for me to have a look at.

Finally, it would be great to get a full Swedish pack for osCmax.

Regards,

pgmarshall
06-18-2011, 11:45 PM
Are you running this on a live server or developing locally on WAMP/LAMP/MAMP? If you are doing it locally - I have come across an issue which is browser specific regarding sessions dropping ... the cart is always shown empty because the browser is not holding the session.

I had this on Firefox running on MAMP (Mac) - solution: define the actual IP rather than use localhost in the configure.php files (catalog and admin).

If you are on a live server - do you have an URL for me to have a look at.

Finally, it would be great to get a full Swedish pack for osCmax.

Regards,

Dillion
06-19-2011, 01:40 AM
Yes I am working on a developing environment using MAMP
And thank you for the tip it resolved the issue!

It would be my pleasure to contribute the Swedish language pack when completed.

Thanks for the help.
Dillion

michael_s
06-19-2011, 03:55 PM
I'm going to back up to the first question that should have been asked:

What is the php error you are getting?

Blank screen = php error. So, check your apache/php error log. It will tell you the exact file that is either missing or misconfigured in your new language pack. Really, it is that easy to figure out. Attempting to do anything before getting this crucial information is like trying to read a book in the dark.

Dillion
06-19-2011, 11:00 PM
Hi,
I have checked through the logs and it seems it gets irrate by a missing image file called pixel_trans.gif.
On Chrome mainly I get your basket is empty after adding product to basket. In Safari I get a blank and depending on file encoding changes "your basket is empty etc" . In firefox all is swimmingly well.

Now I have been the devils advocate and messed with the file encoding within the Swedish pack, to see the affects it has on the application. I have saved the main files as UTF-8.

Is there a rule here about file encoding should all files be a certain encoding?

Dillion
06-19-2011, 11:34 PM
Update: Chrome works and Firefox. Safari still a problem could be some thing to do with the cache.
All files in the Swedish Pack were encoded as western ISO latin 1
Is this the correct procedure?


Thanks
Dillion

ridexbuilder
06-20-2011, 01:56 AM
In an ideal world, I guess we should all be using UTF-16.
To be more specific about your question, UTF-8 should really be the preferred charset but there have been numerous issues in the past. There is a mod that allows simultaneous use of UTF & W. Latin 1 - I thought PGM might have added it fairly recently, in SVN but I didn't spot it with a quick scan....

http://addons.oscommerce.com/info/7879

[ http://addons.oscommerce.com/info/7628 ]
(http://www.oscommerce-addons.com/addon.php?AddonID=12)

Dillion
06-20-2011, 02:15 AM
Well I changed the files to W. latin 1 everything seems to be fine so far.
Flying through the include/language/swedish files. Next the admin.

Just on another niggling problem the footer. Have used the stylesheet to change background an such, but it seems there are two td tags. Went into the main_page.tl
but got a php call in a tr tag. Is this in the Database.

Sorry to bring this up but it's one of those distracting problems.

ridexbuilder
06-20-2011, 02:58 AM
Just on another niggling problem the footer. ....
Better on a separate thread.

pgmarshall
06-20-2011, 03:20 AM
Added to source: r1201 - oscmax2 - osCmax - osCommerce Maximized - Google Project Hosting (http://code.google.com/p/oscmax2/source/detail?r=1201) although I think we have moved some of it around since installing. (Addon: osCommerce: [TiM's osC Solutions] ISO-8859-1UTF-8 dual support (http://www.oscommerce.com/community/contributions,7628)) Regards,

Dillion
07-03-2011, 02:19 PM
Added to source: r1201 - oscmax2 - osCmax - osCommerce Maximized - Google Project Hosting (http://code.google.com/p/oscmax2/source/detail?r=1201) although I think we have moved some of it around since installing. (Addon: osCommerce: [TiM's osC Solutions] ISO-8859-1UTF-8 dual support (http://www.oscommerce.com/community/contributions,7628)) Regards,
Anyway the problem with my contribution is my image based centricity (Visual Artist by heart). Within definitions I like to add images. However I am working on the the text first so I can give it as a contribution. Really appreciate all the work so many have done to make this possible.
Need to get two more shops up and running. Your help is so much appreciated.

All the best
Dillion