PDA

View Full Version : catalog/admin/includes/configure.php not filled out



bjrafferty
03-30-2004, 06:31 PM
During my new installation the catalog/admin/includes/configure.php file was not fully updated, so I tried filling it out partly using information from the catalog/includes/configure.php file.

I don't think that I got it quite right.
When I tried the catalog/admin/index.php script I got the following error :
******
Warning: main(includes/application_top.php): failed to open stream: No such file or directory in /export/home/aehf/public_html/catalog/admin/index.php on line 14

Fatal error: main(): Failed opening required 'includes/application_top.php' (include_path='.:/usr/local/lib/php') in /export/home/aehf/public_html/catalog/admin/index.php on line 14
********

Here is my hand typed configure.php :
#!/usr/local/safe/bin/php
<?php
/*
osCommerce, Open Source E-Commerce Solutions
http://www.oscommerce.com

Copyright (c) 2003 osCommerce

Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://www.aehf.com); // eg, http://localhost - should not be empty for productive servers
define('HTTP_CATALOG_SERVER', 'http://www.aehf.com/');
define('HTTPS_CATALOG_SERVER', 'https://www.aehf.com/');
define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
define('DIR_FS_DOCUMENT_ROOT', '/export/home/aehf/public_html/'); // where the pages are located on the server
define('DIR_WS_ADMIN', '/admin/'); // absolute path required
define('DIR_FS_ADMIN', '/export/home/aehf/public_html/catalog/admin/'); // absolute path required
define('DIR_WS_CATALOG', '/catalog/'); // absolute path required
define('DIR_FS_CATALOG', '/export/home/aehf/public_html/catalog/'); // absolute path required
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
define('DB_SERVER', 'mysqlconnect.catalog.com'); // eg, localhost - should not be empty for productive servers
define('DB_SERVER_USERNAME', 'aehf');
define('DB_SERVER_PASSWORD', '**********');
define('DB_DATABASE', 'aehf');
define('USE_PCONNECT', 'false'); // use persisstent connections?
define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>
**********
I astrixed out the DB_SERVER_PASSWORD

I am having to insert the path to PHP in primary files but not called ones.
I wish there was a list of which was which.
I did add
#!/usr/local/safe/bin/php
as the first line of application_top.php just in case it might help, but it did not.

I am sure that I just typed a path incorrectly in the configure.php
I hope someone can see my error easily.

Thanks so much for your previous help !

dgammon
03-30-2004, 09:29 PM
hhhmmm did you run the install script? If so, did you perform the actions in the install guide? (just checking)

I would first double check that you have the permissions correct on your config files so that the install script can write to it...Then try reinstalling fresh. The errors that you are getting is definately a path problem. I would have to guess becuase you have beginning slashes placed where you have edited your config files.

Also, take out the additions that you made to application_top.php. I can't remember if any sessions are started there but php gets angry even when there is a white space of output before a session.

Your best bet is to check permissions and reinstall per the guide...step by step. Too many installs have been successful to have that bug.

good luck