PDA

View Full Version : Error on Payment Page



Sunlite
03-12-2009, 08:32 AM
Hi everyone, hope someone can help me out. I have an error on my payment page, where it displays the CC info and order info....
Payment Method: MODULE_PAYMENT_CC_TEXT_PUBLIC_TITLE

How do I repair this?

Also how do you add a line to request the CVV number from the card?

Thanks,

jpf
03-12-2009, 09:00 AM
Your MISSING allot of files.... see my other post to you

Sunlite
03-12-2009, 09:13 AM
Thanks again, I was afraid that might be the case. I have downloaded the Oscommerce files as I had a feeling that's what my issue was.... :(

Sunlite
03-12-2009, 11:14 AM
I have checked my files and it doesn't appear that I'm missing anymore, yet the same error is still there. I have overwritten the pages with fresh copies the refer to anything about payment/currency etc and nothing.

I also just realized that in the my account page when logged in, I get the following error:
1054 - Unknown column 's.public_flag' in 'where clause'

select count(*) as total from orders o, orders_status s where o.customers_id = '487' and o.orders_status = s.orders_status_id and s.language_id = '1' and s.public_flag = '1'

[TEP STOP]

My Account Information
Any clues as to where I should start looking for either/or both errors?

My head hurts :p

jpf
03-12-2009, 01:15 PM
Do you have FULL backup of your original server?

Which version do you have (was) on your original server?

There is several version of OSC (and of osCMax) -PLUS there is several other branches that are based on osc....----PLUS who knows what else has been added.

If your missing files - and your putting/replacing them with files from a different version then your creating more problems than you had to start with.

IF you have NO FULL backup - you might be better off starting with a fresh install.

Sunlite
03-16-2009, 09:40 AM
I Just wanted to let you know I've finally corrected both of these issues. The first was just overwriting the cc.php file, I must have missed that one when checking. The second was running an SQL statement which I finally found the answer to here: 1054 - Unknown column 's.public_flag' in 'where clause' - osCommerce Community Support Forums (http://forums.oscommerce.com/index.php?showtopic=290468)


Run this SQL statement to fix your issue. This will create the table elements that are missing.

alter table orders_status add public_flag int DEFAULT '1';
alter table orders_status add downloads_flag int DEFAULT '0';

Thanks again for trying to help me out. :)