PDA

View Full Version : £ in emails, instead of £



pete2007
02-22-2009, 06:23 AM
Hi All,

I recently changed host and had an issue within admin where the £ signs were ?

So I went into admin side of store - admin->localization->currencies and changed back the currency to GBP and £

Then took a look within the catalog/includes/languages/english.php around line 36

define('LANGUAGE_CURRENCY', 'GBP');

Now all new orders are correct with the £ sign, but all previous orders still have the "?" does anyone know how I get change this?

Also the main problem is within the confirmation emails, the £ sign is displaying as £

Any help or advice would be most appreciated!

jpf
02-22-2009, 08:32 AM
£ is for HTML

Ether change £ and enter it as £ or can also try £

pete2007
02-22-2009, 08:47 AM
£ is for HTML

Ether change £ and enter it as £ or can also try £

Thanks for the response.

Change £ from where?

jpf
02-22-2009, 10:23 AM
That would be in your currency settings in admin.

pete2007
02-22-2009, 10:50 AM
That would be in your currency settings in admin.

I haven't got any setting assigned to £

Here are my current admin currency settings:

Code: GBP
Symbol Left: £

jpf
02-23-2009, 05:14 AM
Symbol Left - if you look in your source code is most likly &pound..... use the Ascii equviant or direct entry method.

pete2007
02-23-2009, 05:19 AM
Symbol Left - if you look in your source code is most likly &pound..... use the Ascii equviant or direct entry method.

Hi,

Thanks again for the response.

What file would the source code be located? In includes/english/php?

Sorry what do you mean by Ascii equviant or direct entry method, sorry again I'm still learning in oscommerce.

Thanks!

jpf
02-23-2009, 05:36 AM
Sorry I ment iif you look in any browser - View Source.

Direct entry method - if keyboard not setup for charater - then look up in an ASCII table the numerical value for pound (in Windows - try running "charmap" from the command line/Run Command)- enter that by holding down ALT and then type the number.

OR Ascii equivent of &pound --- but have to use without spaces & # 163 ;

pete2007
02-23-2009, 05:49 AM
Sorry I ment iif you look in any browser - View Source.

Direct entry method - if keyboard not setup for charater - then look up in an ASCII table the numerical value for pound (in Windows - try running "charmap" from the command line/Run Command)- enter that by holding down ALT and then type the number.

OR Ascii equivent of &pound --- but have to use without spaces & # 163 ;

Just tried the Direct Entry Method and it worked!!

Thanks very much for your help, much appreciated :D