PDA

View Full Version : Just installed MS2-Max here's a few tips if your struggling



Anonymous
01-11-2004, 07:10 AM
Hi to every one. Just installed the latest MS2-max version and thought I would leave a few tips for people who are having problems setting up. As it is my first time here I would first of all like to say hello and a very big thank you to Michael Sasek for all his hard work and generosity. I am very glad I found Michael’s site and Max version. I have been trying for weeks to install contribution in the standard MS2 version (most unsuccessfully I might add) and here they are, already done for me. Thank you, thank you, thank you.

Following the OSCdox Installation guide, everything went ok until, Chapter 3, section starting “Using phpMyadmin”. I am a computer engineer not a programmer, until a few weeks ago I never even heard of php or used an SQL database, so this is all new to me. This is how I passed this section.

My web host provides cPanelX making it easy to setup a database. Just select MySQL databases icon from cPanelX, which takes you to MySQL Account Maintenance page. Find the section where it say add database and enter a name in the blank box. Say shop for example and click on Add Database. This creates a database with a filename starting with your user id you used to log on to cPanelX, for example fred . This makes our example database name fred_shop . Now create a User by entering a username and password under the users section on the MySQL Account Maintenance page. Now on the same page in databases section, select the user and database just created above, make sure all privileges is selected then click on “Add User to Database”. That’s it. The database serve is localhost. With this information I was able to proceed and successfully complete the rest of the installation.

Once installed, log into your /catalog/admin, using the default login, email address : admin@localhost.com password: admin . Now change this default password straight away by clicking on My Account (butterfly icon). Then edit, enter admin as the password again, then confirm. And carry on from there. Incidentally, when adding new members under the administrator menu, you are not asked for a password, a random password is emailed to the address entered for that member. The new member can then log on to admin and change there password in the same way.

Now click through the menus one by one and you should find everything installed ok (a credit to Micheal’s hard work) when you get to configuration, select cache, then cache directory and edit, change the cache directory. The default temp directory on my server was located in the root directory /tmp/. Check where yours is, if you do not have one create a temp directory.

Under catalog you will find Define Mainpage. This gave me an error on my installation; I was not able to write to mainpage.php. This was easily corrected by changing the /catalog/includes/languages/English/mainpage.php file permissions to 777.

Once you have been through the menus and are happy, backup your site. Download it to your computer using your ftp program or use your host cPanelX backup option if you have one.

Hope some one finds this useful. Now onto some modifications.

Anonymous
01-24-2004, 06:34 AM
Do I have to change the use cache from false to true as well?

Mibble
01-25-2004, 07:04 AM
even though there is nothing to execute on the mainpage.php, it should be set at 666 for permissions.

by the way, where did you find the download? i am sstill hunting for it!

BTW, if you change your cache from falst to true, please make sure you have permissions to the folder you have cache pointed to, else you will get errors.

knullhund
02-05-2004, 09:28 AM
I wish all, if not most members, would post information in the format you posted. I accomplished more with your information in a few minutes than trying to hunt for info in the forum for hours on end. Thank you for simplicity and specificity.
Knullhund

michael_s
02-05-2004, 01:14 PM
Yes, I agree. Nice post! This will be helpful to many.

Kristine
04-02-2004, 01:25 PM
..wrong thread.. sorry

penzman
08-06-2004, 10:09 AM
Once installed, log into your /catalog/admin, using the default login, email address : admin@localhost.com password: admin


I was just about to swallow the cyanide pill when i stumbled upon this...
Hour and hours searching and trying to guess how to do it...

Thanks!!!

mfleeson
08-31-2004, 05:13 AM
Under catalog you will find Define Mainpage. This gave me an error on my installation; I was not able to write to mainpage.php. This was easily corrected by changing the /catalog/includes/languages/English/mainpage.php file permissions to 777.

One thing to mention, on unix the mainpage.php files are case-sensitive so you need to:
chmod 666 ./includes/languages/english/mainpage.php
chmod 666 ./includes/languages/espanol/mainpage.php
chmod 666 ./includes/languages/german/mainpage.php

Copy/pasteing /English/ gives an error on the latest 1.7 build.

Thanks a lot for the rest of the post, I suggest the addition of the user/password for admin to be added into the installation documentation.

Cheers

Mark

innovations
10-25-2004, 11:57 PM
I am setting my site up on my local machince, and I made sure that the english/mainpage.php file was not set to read only, but I still get an error when attempting to change my main page in the admin panel.

Any help would be appreciated!

mfleeson
10-26-2004, 02:58 AM
If its on your local machine, just use a decent html editor?, alternatively change the files to 777, i.e. chmod 777 ...../mainpage.php

innovations
10-26-2004, 11:49 AM
I am using Dreamweaver MX 2004...

seandon01
11-10-2004, 04:09 PM
THANK YOU FOR THIS TOPIC!!! I was gonna kill m computer until i found this post.. solved my simple problem

doumawis
02-05-2005, 02:02 PM
i am not despered, but if you are in hurry to set up a shop than i can imagine that you don't like this sucking affair of installation.

The problem is the amateuristic installation manual with not all relevant details: you have to look in the forum or use your commen sense.
Well trial and error: that sucks and :missionary:

The positive site of the story is that you are forced to study the subject databases and has to think about it.

:guitar:

doumawis

nathanwheeler
02-16-2005, 04:02 AM
oki, first post , sorry if i do wrong.

IF you run oscommerce with a PHP5! installation you will get an empty screen when opening the
adminitsration page of your newly installed oscommerceMAX OR MS2
GO TO directory: admin/includes/classes/ and open upload.php , there is on line 30....
// self destruct
$this = null;

THIS should be :
// self destruct
$this == null;

jaruss
02-17-2005, 06:13 PM
I too appreciate this post. I am having difficulty understanding the file structure for osCmax 2.2.

The templates directory has main_page.tpl.php

Is this the file that I need to edit to modify the home page?

Do I have to rename it since the admin menu is looking for main_page.php?

Thanks for any help.

jaruss
02-18-2005, 04:29 AM
Ok, I've been reading more and understand that it is the main_page.tpl.php that I need to modify. Why does the admin menu catalog/contents/Define Main Page instruct you to modify mainpage.php? Am I supposed to rename main_page.tpl.php?

Sorry if I'm being really slow here... I'm not a programmer just someone trying to get this working. :hmm:

Thanks.

michael_s
02-18-2005, 08:20 AM
Define main page modifies the center content of the index page of your shop. main_page.tpl.php modifies the actual template of your site design, not any content.

thatsme
04-22-2005, 02:05 PM
After installation on an apache php5 server I did this:

THIS should be :
// self destruct
$this == null;

but that message follows me now into my deepest dreams:


open_basedir restriction in effect. File(/includes/languages/german/login.php) is not within the allowed path(s):

Why I get this message on a new installation?

paulM
04-23-2005, 01:10 AM
// self destruct
$this = null;

THIS should be :
// self destruct
$this == null;While this does help, it's not correct. "$this == null;" has no meaning here (that's why it helps as much as commenting the line out). It checks if $this equals null and returns true or false.

In stead of the above you could as well comment it out like

// self destruct
//$this == null;
But assuming the programmer had a reason to set $this to null, I would use:

// self destruct
unset($this);myself

newtothis
06-16-2005, 01:33 PM
I have problems too,I have done everything to get the define Main_Page writable but nothing, I logged in as the administrator with the regular default account admin@localhost.com and change the attributes to folder: cache,temp,define_mainpage/admin, languages and nothing..

michael_s
06-16-2005, 02:05 PM
newtothis, you are changing permissions on the wrong file. To get define mainpage working you need to chmod 777 /includes/languages/english/mainpage.php

newtothis
06-17-2005, 01:32 AM
thanks Michael! now my webshop is working, hats off for you!! :yourock: