PDA

View Full Version : After installation



Anonymous
01-07-2004, 12:48 PM
Hi,
I get this message:

Warning: session_start(): open(/tmp\sess_73c1858554795b3130cc10582adde104, O_RDWR) failed: No such file or directory (2) in C:\Inetpub\wwwroot\catalog\includes\functions\sess ions.php on line 67

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at C:\Inetpub\wwwroot\catalog\includes\functions\sess ions.php:67) in C:\Inetpub\wwwroot\catalog\includes\functions\sess ions.php on line 67

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at C:\Inetpub\wwwroot\catalog\includes\functions\sess ions.php:67) in C:\Inetpub\wwwroot\catalog\includes\functions\sess ions.php on line 67
Warning: The sessions directory does not exist: /tmp. Sessions will not work until this directory is created.


What should i do?

Regards

/ANNA

michael_s
01-07-2004, 01:45 PM
Linux: if you have root server access, create the /tmp directory in the main server dir, and make it writeable. If you do not have root access, change the sessions settings in the admin and catalog configure.php files to say 'mysql' and the problem will go away...

Windows: create a /tmp folder on the C: drive and make it writable. You may have to experiment where to put the tmp dir. Start in c:, and work your way down the webserver directories until it works. Changing the configure.php session setting to 'mysql' will work on windows systems as well...

jpf
01-08-2004, 05:42 AM
The quickest solution is as Mike pionted out - store session in MySQL....

The better solution (in a bit more detail)....
Look in your php.ini to see where your "tmp" directory should be. More than likely c:\tmp or c:\php\tmp. Make sure it exists. THEN MAKE SURE on NT/2000/XP/2003 servers the "IUSR" has R/W/M permission on this directory. Without that set the web server (and thus php) can not use this directory.

Anonymous
01-08-2004, 12:11 PM
Hi JPF,

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
upload_tmp_dir = C:\PHP\uploadtemp ; temporary directory for HTTP uploaded files (will use system default if not specified)

i have created this folder, and i stil get same message, ther "user", "admin" have modify permission.

/anna

jpf
01-09-2004, 05:40 AM
We are talkin about sessions - not uploads.....

Look for something like:
session.save_path = C:\PHP\sessiondata
or
session.save_path = C:\PHP\tmp
or
session.save_path = C:\tmp
or
session.save_path = /tmp

janehamilton
01-09-2004, 07:08 AM
Quickest way I know to locate your OS Commerce php settings (ie what directory session.save_path points to etc) is via entering http://yourserver/catalog/admin/server.info.php (replace yourserver with localhost or your domain name whichever applies) into your browser.

For your problem look under the heading 'session' in the column Directive you will them be able to find where session.save_path points to on your system. The Local value column has a value that you can set via the OS Commerce admin panel under Configuration-Sessions-Session Directory, click edit and enter say /example (this is just to show you how the value you enter here shows up in your server_info.php file) this will then be the directory which is mapped to the Master value which in my case (on my system) is C:\PHP\sessiondata. You would then as mentioned need to set permissions via your servers settings to enable this directory to be written to.

I am new to OS commerce and PHP but I think it is better to get your sessions written to a file in a directory rather than writing to the database which is what the mysql setting does by adding mysql as the value to the STORE_SESSIONS constant in the configure.php file

Anonymous
01-31-2004, 09:55 PM
Jane,
The correct url to the server info page is actually http://yourserver/catalog/admin/server_info.php

Note the underscore instead of a period.

Hope everything is working out for you now, I'm still having what appears to be one last difficulty, but it's worth the wait. ;)

Regards,
Obewanz