PDA

View Full Version : install problem on W2000



Anonymous
12-03-2002, 11:58 PM
Hi,

I am trying to install on W2000 running IIS locally. I am not very good at php and on the first screen of installation came up the following error msgs.

Notice: Undefined index: step in c:\inetpub\wwwroot\vesaire\install\install.php on line 18

Notice: Undefined index: DIR_FS_DOCUMENT_ROOT in c:\inetpub\wwwroot\vesaire\install\includes\functi ons\html_output.php on line 15

I had searched php sources on net but could not find the answer. Help would be appreciated.

Thanks
Ugur

kenson
01-08-2003, 04:32 PM
Hi Guys! I also face the same problem as above user.
Currently i have try install on my Win XP Pro Environment.I have also (PHP 4.23, MySql3.25, IIS6).When doing the first time installation.On the install page i get some variable error as below:
Notice:Undefined index: Step in
C:\inetpub\wwwroot\envo\home\install\install.php
Notice:Undefined variavle: DIR_FS_DOCUMENT_ROOT
Notice:Undefined variavle: HTTP_SESSION_ROOT
Notice:Undefined variavle: REQUEST_URI
Notice:Undefined variavle: DIR_SESSION_VARS
...etc.

The installation can not be proceed.
But those error not happen in LINUX environment.
Can anyone can suggest me the solution!
Help would be appreciated! :lol:

Thanks!

skyborder
01-08-2003, 10:47 PM
I have installed it in win2000 sucessfully.
I didn't meet the errors that you found,but every time I open it,my brower will give me a warning:

Warning: I am able to write to the configuration file: D:\\PHPWEB\\catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

The help guide told me use "chmod 777 configuer.php" in unix,but I have changed the permissions in win2000.

how to delt with it?

Thanks.

michael_s
01-08-2003, 11:15 PM
In win2000, you have to use windows explorer. Right click the configure.php and select properties in the context menu.

In properties, click the "read only" checkbox. This should stop the warning message for win 2000