PDA

View Full Version : Auth .NET cURL and IIS



rkah
04-24-2008, 09:47 AM
I've read a considerable amount on this and resolved many other issues but this one is kicking my ar$e. My Setup:
Server Host:(x.x.x.x) Database Host:localhost (127.0.0.1)Server OS: Database:MySQL 5.0.51a-community-ntServer Date:04/24/2008 12:38:37 Datebase Date:04/24/2008 12:38:37Server Up Time:http://www.iaink.com/admin/images/pixel_trans.gifHTTP Server:Microsoft-IIS/6.0PHP Version:5.2.5 (Zend: 2.2.0)


I have verified that Curl and OpenSSL are both enabled in PHP:

OpenSSL support enabled
OpenSSL Version OpenSSL 0.9.8e 23 Feb 2007

cURL support enabled
cURL Information libcurl/7.16.0 OpenSSL/0.9.8e zlib/1.2.3

My issue is that I get the Cant connect to server issue check server settings issue. With IIS do I need to do the nasty business of rebuilding PHP from source with cURL integrated?
REVISED: The answer to that is NO, PHP has it built in already. I believe I read this post correctly:libcurl - using PHP/CURL on IIS (http://curl.haxx.se/libcurl/php/iis.html)

So that is out of the question...and I specified my path as c:/Program Files/PHP/EXT which is where it is and it shows enabled on the PHPINFO page. do I need to add or remove the trailing "/" or maybe put php_curl.dll on the end of all of that for my cURL path?

rkah
04-25-2008, 11:11 AM
OK having done a lot of homework on this one, and still no dice on checkout going all the way through.I switched the cURL Compiled option to "Compiled" and everything worked all the way through! Even though it says to leave it at not compiled for windows users.

automotiveuk
04-25-2008, 02:39 PM
Hi Have uncomented the extension in php.ini?

extension=php_curl.dll

rkah
04-28-2008, 10:10 AM
Yes, I was able to run a test script using curl to "GET" other websites. Just as a sanity check to know cURL really was enabled. It just wouldnt work in osCMAX, until I set the Auth .NET module to COMPILED.
Keep in mind that I was running php FastCGI under IIS. I came across some info that said cURL is compiled into PHP on the windows installation package. More info is available in the link I posted above.

michael_s
04-28-2008, 12:01 PM
The Authorize.net module must be set to compiled. That is the requirement of the module, it requires using the PHP compiled curl, it cannot use the binary.

It is a limitation of the mod version that is installed.

rkah
04-28-2008, 01:01 PM
I understand that now....but this is what threw me off from the beginning.
This appears in oscMAX 2.0 using the Auth .NET module:

"cURL Setup
Whether cURL is compiled into PHP or not. Windows users, select not compiled."


That was the source of my frustration/grief.