View Full Version : Problem with confirmation of payment

04-09-2008, 05:09 PM
I have Authorize.net installed ok and it works and accepts the payment and the payment goes through.

However, on the customer side of things, the cart is showing a problem with the transaction, telling the customer there was a problem with the card.

Where do I even start looking to figure this one out?


04-10-2008, 12:16 AM
okay, the return information is in the URI of the return (look in the location bar of the browser and you will see the error message). Unfortunately, for most errors it is minimal (ex: "Your card was declined") and rather than dick with it and find out WHY it isn't returning the errorcode well and displaying them properly (see what happens if you don't enter a CSC to see the proper way an error should be displayed), I have suggested to a customer that they start using a different payment processor.

04-10-2008, 05:00 AM
Is the transaction authorized and captured in the authorize.net admin panel (not osC)?

Is the status Declined or Captured/Pending Settlement?

That is where I would start first.

04-27-2008, 12:15 PM
Sorry to take so long getting back to this, time is a killer. I think I need a 40 hour day AND a clone.

Yes, the transaction is posting to authorize.net just fine, everytime.

Here is the EXACT (except for the 'mysite' sub) URL from the browser and the error message at the top of the cart screen

There was an unspecified error processing your credit card.

https://www.mysite.com/catalog/checkout_payment.php?error_message=There+was+an+un specified+error+processing+your+credit+card.&osCsid=c1bcb0b9ce12fbf1b2cbcd13d7b78b9c
(https://www.mysite.com/catalog/checkout_payment.php?error_message=There+was+an+un specified+error+processing+your+credit+card.&osCsid=c1bcb0b9ce12fbf1b2cbcd13d7b78b9c)

Any ideas? Where can I find that OSC Error code ID?

05-12-2008, 04:09 AM
So am I to assume OSMax (like OSCommerce) is intended for use only by those who are fluent in PHP and can do their own independent troubleshooting?

I have tried to HIRE someone with no results and I understand that it is against the rules to solicit or offer such services here (as if anywhere else would be more appropriate) ...and I've asked for a direction in which to look...not for someone to point out the exact problem and fix it for me.

Am I missing something here?

05-12-2008, 07:16 AM
Yes, assume that you should be willing to do a little work to solve your issues.

That error leads me to believe you server is not compiled with curl+ssl in php, or the module is not detecting curl. I have never seen a payment actually get to auth net when that error is thrown.

Are you in test mode for either the module or auth-net? Put both in live mode.

05-12-2008, 12:26 PM
Yes, assume that you should be willing to do a little work to solve your issues.

I guess the question I would have in reply is why do you think I haven't done as much as I can on my own, or do not expect to do a LOT of work to solve my issues? I've spent hours upon hours looking through the files of this thing looking for a clue as to where the response is interpeted. I've talked to Authorize.net on several occasions. I spent many hours searching for similar issues on the forums...only to find many questions and few answers.

That error leads me to believe you server is not compiled with curl+ssl in php, or the module is not detecting curl. I have never seen a payment actually get to auth net when that error is thrown.

Well, you have now.

I have talked to the host and they solved the curl issues. And yes, I'm set to compiled.

As I said, the charges go through to Authorize.net just fine, and post to my credit card account just fine. However, the user side still shows the URL and error message I posted previously.

Are you in test mode for either the module or auth-net? Put both in live mode.

My site has been using Auth.net for some years now with a different cart without issue. I am live.

I assume you mean "production" ...here are my authnet settings (obvious edits)

Authorize.net Consolidated v1.7 by Austin519
Enable Authorize.net Module

Login Username

Login Transaction Key
transaction key (same as is working with the other cart)

cURL Setup

cURL Path

Transaction Mode

Transaction Method
Credit Card

Processing Mode
Authorize Only

Sort Order Of Display

Customer Notifications

Accepted Credit Cards
Visa, Mastercard, Discover

Is this module compatable with the AIM method? Authnet said that I shouldn't have to do anything differently if I was using AIM. I know I am on the other cart...and really don't want to mess it up until this cart is ready to take over. Even then, I would like to use the other cart for some special purposes seperate from the main site.

Michael, I appreciate your help. However, this cart is completely devoid of documentation in many areas, and it seems unless you have a PHP background, you cannot make this thing work without help. As I said, I've even inquired of hiring help to no avail. I am only asking for directions so that I can learn to solve the problems with this cart for myself. If I wanted someone else to do everything, I'd have just used the cart offered by my host. --not my style.

05-17-2008, 07:55 PM
I guess this proves my point. OSCommerce and OSCMax aren't meant for those without advanced PHP programing skills or ready access to someone who is a PHP fluent.

If the only help one can get is the the online forums....I'll buy a commercial cart. I should have done this in January when I started looking at these carts.

05-29-2008, 09:05 AM
Hi, Jack here:

I got a problem the looks alot like zaps problem (a recent, unresolved thread that included a bit of impatience if I recall correctly).

Ok, test account was working perfectly, payments were all lovely and posting fine etc.

Now, today I was testing again and something ugly and nasty came up....
When making an order, I get the error in the url "card has unspecified error" but...the order does indeed post to Authorize.net. I can see the order....

The only significant change I can think of that I made was to install the zone shipping payment module in MVS. I uninstalled the zoned shipping already. Still does not work..humm. Could it have to do with SEO?

Uh-oh...what do I do now?

PS. This is how I feel: :confused:

Here are some of my server errors:
[Fri May 30 08:30:42 2008] [error] [client] Directory index forbidden by rule: /usr/local/www/vhosts/site.net/httpdocs/images/, referer: www.site.net (http://www.site.net//index.php)

[Fri May 30 09:04:11 2008] [error] [client] Directory index forbidden by rule: /usr/local/www/vhosts/site.net/httpdocs/images/, referer: https://www.site.net//checkout_confirmation.php?osCsid=7nu47uebbfpplqhu1 u5khaolu7

[Fri May 30 09:07:55 2008] [error] [client] Directory index forbidden by rule: /usr/local/www/vhosts/site.net/httpdocs/images/, referer: www.site.net (http://www.site.net//island-lighthouse-p-147.html)

[Fri May 30 09:11:43 2008] [error] [client] PHP Warning: Unknown: open_basedir restriction in effect. File(/var/tmp) is not within the allowed path(s): (/usr/local/www/vhosts/site.net/httpdocs:/tmp) in Unknown on line 0, referer: https://www.site.net/admin/vendors.php?selected_box=vendors&page=1&vendors_id=3&action=edit&osCAdminID=ch6ol33dnllmgk9t3t94uj5c10

[Fri May 30 09:11:43 2008] [error] [client] PHP Warning: File upload error - unable to create a temporary file in Unknown on line 0, referer: https://www.site.net/admin/vendors.php?selected_box=vendors&page=1&vendors_id=3&action=edit&osCAdminID=ch6ol33dnllmgk9t3t94uj5c10

[Fri May 30 09:17:38 2008] [error] [client] Directory index forbidden by rule: /usr/local/www/vhosts/site.net/httpdocs/images/, referer: https://www.site.net//checkout_payment.php?error_message=There+was+an+un specified+error+processing+your+credit+card.&osCsid=7nu47uebbfpplqhu1u5khaolu7

05-30-2008, 09:06 AM
Well, here is a little more of the unfolding saga:
The errors listed are about Apache permissions problems and I don't think they have anything to do with the CC payment stuff. The module continues to give me "There was and unspecified error processing your credit card" error, but still registers a payment on Authorize.net. Something is wroooonng! haha...

Ok, if anyone out there would like to take a swipe at this, I would be giving thanks...haha.


05-30-2008, 11:03 AM
Wow, the problem sticks there. I cannot say what I might have done, that's the worst of it. It something with permissions affecting the Auth.net mod?
Too crazy...

Answer wanted, dead or alive.
Preferably alive.

05-30-2008, 01:49 PM
Post your php version and configuration (safe mode? open basedir restrictions? version? and custom mods?)

If it was previously working, and now is not, what changed in that time frame? Did your host change security settings? Upgrade Curl or php? Any other changes?

05-30-2008, 01:51 PM
One other suggestion. Do a clean osCMax install without MVS installed and see if the checkout works...

06-02-2008, 08:13 AM
Ok, I did something to check what was actually being returned:

In authorizenet.php in this function:
function before_process() {

I went to line 224 and added the bold just to see what $x_response_code was throwing back.

if ($x_response_code != '1') {
//several lines of if-then-elseif etc

else {
tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYME NT, 'error_message=' . urlencode('There was an unspecified error processing your credit card.').urlencode("$x_response_code"), 'SSL', true, false));
Ok, so then I did an order and looked at what got returned. (I have tried to make it a little more readable.)

https://www.site.net//checkout_payment.php?error_message=There+was+an+un specified+error+processing+your+credit+card.
1 1 1 This+transaction+has+been+approved.
2oyPD2 Y 508441341 1-31-inch+Codfish+Shelf%2A%2A
757.50 CC auth_capture 1 Andrea Festurette 123+South+St
Cunningham Alabama 63234 United+States 1234567890
jackstrit%40yahoo.com Andrea Festurette 123+South+St Cunningham Alabama%7C63234%7C
United States D5505533243C1AF564366103D785BCFB


So it looks like $x_response_code == 1 1 1 This+transaction+has+been+approved.
2oyPD2 Y 508441341 1-31

and because it is not just "1" it is throwing the default error...any further advice besides reinstalling a clean OSCMax? (Ok, I admit it, I don't really want to start over. :mad:)


06-02-2008, 11:36 AM
Problem Solved!:dance:

In file authorizenet.php

line 207

$response_vars = explode('|', $response[0]);Notice I used the pipe '|' delimiter instead of the comma ','. That is how this string is delimited. It works now. Maybe only the testing account is delimited this way, maybe authorize.net changed the way they sent back information, maybe, maybe...

Anyone have any comments on this?? Besides "yeah, I knew that" haha...:rolleyes:


PS. Zap..you should thank me!

03-26-2009, 10:48 PM
I've been having this issue for a few days.
I would assume that the delimiter would have to do with auth.net settings.

With both the module and auth.net in LIVE mode, I can get a credit card to process at auth.net, but the same response at oscmax EVERY time
"There has been an error processing your credit card https://landolace.com/catalog/images/pixel_trans.gif Please try again and if problems persist, please try another payment method."

and yes, curl is setup correct (although I dont know why there is no setting in the 2.0 to specify compiled or not compiled... and if the setting is always "compiled", why is there a space to put the curl address?

i've done ALOT of oscommerce stores just fine.. wanted to try oscmax and end up very frustrated with the auth.net module.

anyone have a clue on why the response is always an error on the osc side but the card gets processed???

03-27-2009, 07:21 AM
What version of osCMax? Are you using 2.0.1 Stable or some other version? I want to try to help, but without some basic info, not much I can do.

03-27-2009, 09:13 AM
yes, i'm using 2.0.1 stable, Unix, shared host, my own SSL with curl compiled into PHP, fallback template (i'm wondered if it was the template but the others showed the same error).

I was using R4 and upgraded to 2.0.1 yesterday, completely overwriting ALL files, only thing left was the images transferred to the new directory.

I have another oscommerce store on the same server, not oscmax, and that one works fune with auth.net

03-27-2009, 09:56 PM
To resolve your problem, make sure this is blank in the authorize.net module configuration:

cURL Program Location

I just tested this with my authorize.net account and it works fine as long as this value is not set. The module is programmed to properly use the Curl functions compiled into php, and when the path to the binary is set, it messes that up.

Give it a try and let me know if that fixes your issue. The other thing to try is NOT setting the MD5 Hash. Leave that blank too.

03-27-2009, 10:59 PM
leaving the curl field blank does not help.

MD5 is empty

i could not find any instructions in the 2.0.1 package for this module, is it a rework of a contribution on oscommerce.com? maybe the details in a contribution file would help me.

i suppose that whatever the problem, the results are not returning to oscommerce, hmmm

03-28-2009, 12:16 PM
This is the official authorize.net module from osCommerce. There are no changes to it.

It works fine for me when I enable it. I just enable, add my Authorize.net login and transaction key. I get no errors whatsoever, all orders I do process without any problems.

I suggest checking your error logs to see if anything shows up there.

03-28-2009, 12:28 PM
I got it to work LATE last night... phew!

There are a few important settings in Authorize.net that throw back alot of errors if they are incorrectly set.

11-02-2009, 10:57 AM
such as?....How did you rebound?