PDA

View Full Version : Check Money Order processing error



Anonymous
10-26-2003, 12:23 AM
I've just tried to use the check/money order processing option and when moving from order_confirmation.php I get the following error:



Warning: exec,system,passthru,popen() has been disabled for security reasons in /home/domains/wargamestore.com/user/htdocs/includes/modules/authorizenet_direct.php on line 69

Warning: Cannot modify header information - headers already sent by (output started at /home/domains/wargamestore.com/user/htdocs/includes/modules/authorizenet_direct.php:69) in /home/domains/wargamestore.com/user/htdocs/includes/functions/general.php on line 29


I have Paypal IPN and Check money order options selected. I don't think I have made any changes that would affect this (famous last words)

Can anyone help please?

michael_s
10-26-2003, 08:27 AM
Looks like a server config issue. Your server has exec,system,passthru,popen() disabled in PHP. I think that is what the problem is.

Anonymous
10-26-2003, 10:15 AM
I don't understand what you mean. Is this a problem with my ISP? Why is the error found in authorizenet_direct.php when I am not using this payment method? I would have thought checks would be no problem because it doesn't have to invoke any further processing. Any further help with this would be appreciated.

warrenthewindmill
10-28-2003, 09:23 PM
Couldn't remember my password when I posted this so listed as a visitor.

The sales I have put through check/money order processing appear to work ok:

The sale is posted and can be viewed in admin
The email confirming sale is sent to customer

I just can't figure out why I am getting this error message or where to look.

Anonymous
10-29-2003, 05:39 AM
To get rid of the second error you have, go to includes/modules/authorizenet_direct.php and go to the end of the file, put your cursor next to the last > and hit delete and then save.

warrenthewindmill
11-03-2003, 11:10 AM
To get rid of the second error you have, go to includes/modules/authorizenet_direct.php and go to the end of the file, put your cursor next to the last > and hit delete and then save.

Tried this but still getting the error. I've tried searching for help in the forums but have found nothing. Without a solution to this my site is a non starter. help please?

warrenthewindmill
11-03-2003, 10:15 PM
Warning: exec,system,passthru,popen() has been disabled for security reasons in /home/domains/wargamestore.com/user/htdocs/includes/modules/authorizenet_direct.php on line 69


refers to the path required for cURL. I searched the forums here and over at oscommerce and as a result checked my server information to see if cURL was installed on my server. I saw the following:



CURL support enabled
CURL Information libcurl 7.9.5 (OpenSSL 0.9.6b) (ipv6 enabled)


I tried to find the cURL directory on my server but it could not, so I mailed my host to check. This is the reply I got:


We don’t currently provide the service or functionality for 'curl' that you have
contacted us regarding. We will consider your request in our future plans
however this will not be available in the very near future.


I am currently planning to use Paypal and check money/order processing so could I get by for now without changing provider?
If so how would I get rid of this error? Remove everything related to authoriizenet?

Have my provider answered my query correctly? If so why does my server info tell me that cURL is installed?
Given a very rudimentary understanding of what cURL does I am amazed that my web host doesn't provide it. They are a major UK provider with full page ads in all the computer comics.

Help please

michael_s
11-03-2003, 10:24 PM
Yes, you will need to disable the call to Authorizenet in your checkout page, as that requires cURL compiled into PHP. There is actually a thread on this, as it seems there is a small bug in the Anet code. Here is the thread, you can try his solution:

http://oscdox.com/index.php?name=PNphpBB2&file=viewtopic&t=1274&high light=authorize+net+bug

warrenthewindmill
11-04-2003, 10:11 AM
Thanks very much for that it completely solved the problem.
I also mailed my provider again and their first response was garbage. cURL is installed in /usr/bin/curl so I wonder why it wasn't working properly? One to solve on another day I reckon, when I get round to installing protx maybe.

michael_s
11-04-2003, 10:39 AM
The reason it is not working, most likely is because even though curl is installed on your server, it is not compiled into PHP. The authorize net module requires curl support compiled into php. That is why it was not working.