PDA

View Full Version : MS2 Max 1.5 - cannot go back to index page



goldie
10-18-2003, 03:32 AM
All went well with orders until " your order has been processed"
When click continue, it should go back to non secure index page. But
it shows a 404 page with the file path still inside the https://...../checkout_success.php=action..

I tried it on two different servers with share SSL, both had the same problem.

ANY HELP? No white space in index and checkout_success.php.

TIA

Anonymous
10-18-2003, 02:42 PM
No Reply?
I am updating the version I am using, its MS2 MAX 1.5.2

Anyone have this problem?

If I don't use the SSL , this problem dissapeared.
So, its a problem going out from SSL to non SSL index page.

Got any suggestion?

TIA

Anonymous
10-21-2003, 10:19 AM
May be you can check this catalog/configure.php and point out where is the snag in going back to index.php
I'm using share SSL

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://www.abc.com'); // eg, http://localhost - should not be empty for productive servers
define('HTTPS_SERVER', 'https://secure.webhost.com'); // eg, https://localhost - should not be empty for productive servers
define('ENABLE_SSL', true); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'www.abc.com');
define('HTTPS_COOKIE_DOMAIN', 'https://secure.webhost.com/~site3/store');
define('HTTP_COOKIE_PATH', '/store/');
define('HTTPS_COOKIE_PATH', '/~site3/store/');
define('DIR_WS_HTTP_CATALOG', '/store/');
define('DIR_WS_HTTPS_CATALOG', '/~site3/store/');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

Come on guys, hope this will give you an idea.
http://www.abc.com/store (don't click,its a make up) was giving during installation but in the configure.php, as you see is without store, but works fine. Placing /store behind manually makes the website disfigured, most borders dissappeared.

You need to read all three updates.
Cheers