PDA

View Full Version : Multi Vendor Shipping



drillsar
01-23-2008, 11:22 AM
A new project_project entry has been added:
Multi Vendor Shipping - osCMax - osCommerce Maximized (http://www.oscmax.com/project/mvs)



This contribution changes the way Oscmax handles shipping. You can now set the shipping parameters for each product individually. All of the following (and more) are possible:
1. Most products ship by a selection of standard shipping methods, but certain large and heavy items ship by truck.
2. Products ship from one of two or more locations.

drillsar
01-24-2008, 04:22 AM
It's very buggy yet, It's not working at the moment, I think it has something to do with the modules in admin. Maybe someone can help

drillsar
01-25-2008, 02:06 PM
Ok I fixed it, now it should work. Thanks

drillsar
02-03-2008, 06:14 PM
I fixed the usps.php to integrate with the new usps system also added insurance to it.

download MVS1.1c

drillsar
02-04-2008, 12:12 PM
Problems I found in usps.php

usps.php, goto line 177 and fix the typo
CODE
if (($maxins == 0) || (constant('MODULE_SHIPPING_USPS_INSURE_' . $vendors_is) == 'False')) {
Should be
CODE
if (($maxins == 0) || (constant('MODULE_SHIPPING_USPS_INSURE_' . $vendors_id) == 'False')) {

Then look at line 227. You'll see this
CODE
$uspsQuote = $this->_getQuote();
Change it to
CODE
$uspsQuote = $this->_getQuote($vendors_id);

jack_strit
03-13-2008, 07:18 AM
Hello,
Nice to meet everyone here. Thank you for these great contributions to the OSCommerce community. I have just installed Multi Vendor Shipping and I want to tell everyone that the SQL is missing a few small details that will muddle up your permissions for MVS. I did not know where to include the fixes so I will simply past one of them here. You may need to do something similar for the files 'prods_by_vendor.php' and 'orders_by_vendor.php'. This is a sample to fix the permissions for vendor_modules.php:
#:no:BE SURE TO REPLACE 'oscmax2' WITH WHATEVER YOUR DATABASE #NAME #IS!!!!!!!:no:
#
# mvs.sql
# For MVS V1.0 2006/03/25 JCK/CWG
# osCommerce, Open Source E-Commerce Solutions
#

#
# Fix for compatibility with multi-admin mod
#for table `admin_files`
#by jack_strit 2008/03/13
#Fixes problem with permissions which makes "Manage" button not work in #Vendor Manager
#
#Remember to replace 'oscmax2' with your database name.

INSERT INTO `oscmax2`.`admin_files` (
`admin_files_id` ,
`admin_files_name` ,
`admin_files_is_boxes` ,
`admin_files_to_boxes` ,
`admin_groups_id`
)
VALUES (
'127', 'vendor_modules.php', '0', '124', '1'
);

mithereal
07-03-2008, 07:44 PM
will you post the other changes you had to make to the db to work im still getting no access but the manage function works correctly thx.

jack_strit
07-04-2008, 07:57 AM
Well, the stuff I posted fixed an issue with the oscmax admin giving a permissions error...that is all. I am not sure why you are "not getting access". Maybe you could be more specific as to what you exactly do and what exact errors you get. You should concentrate on the major errors first, since trying to fix more then one error at a time is very difficult.

The biggest thing I would suggest is that (if you don't already) you should learn some basic stuff about SQL. It is very simple to learn the basics of "SELECT" and "UPDATE". You will then be able to tell basically what is going on when you look at SQL. You don't necessarily have to be an expert to understand what the programmer was trying to do. Then you can modify what you need and kind of understand what is going on. That is what I try to do.

The other modifications I did were almost exactly the same as the modification I posted except I was including other files that had given permission errors when I tried to go to them.

If you can give me an exact description of your problems, maybe I or one of the other people here can help you. I am glad my post above helped you some also...

Saludes

J

mithereal
07-04-2008, 01:19 PM
the error i am getting is Access Denied http://swliquidators.com/store/admin/images/pixel_trans.gif No Right Permission Access Please contact your Web Administrator to request
more access or if you found any problem.when i click vendors order list and move products between vendors.

The above fix fixed the manage function under vendors i just dont have permissions for the items stated above can someone tell me what i need to modify ot have permissions?

jack_strit
07-04-2008, 08:38 PM
What page is it attempting to request?

mithereal
07-31-2008, 03:57 PM
ok well i got the permissions sorted out, just read a sql book all makes sense now thx for the advice.
I have another error when i try to buy items from multiple vendors( the default vendor and one I added) redirects fine .

However when I checkout an item from a vendor (or multiple vendors I have created)
It gives me "The page isn't redirecting properly,ffx has detected that the server is redirecting the request for this address in a way that will never complete" error.
The Title bar shows this which I think is the
error can you gimme some insight as to where to find the answer.
|titlebar|

'xxx/store/checkout_shipping.php?error_message=ERROR_NO_SHIPP ING_SELECTED_SELECTED&osCsid=3f97900'
(http://xxx/store/checkout_shipping.php?error_message=ERROR_NO_SHIPP ING_SELECTED_SELECTED&osCsid=3f97908ab663d8680cf614284f8c3a16)

jack_strit
08-01-2008, 08:07 AM
Hi!
Are you sure you have applied a shipping mod to each vendor?

--J

jack_strit
08-01-2008, 08:08 AM
Also, are you sure your products all have vendors associated with them?

mithereal
08-01-2008, 11:46 AM
yup my vendors do have shipping mods assigned, all my products have vendors assigned
What I did:
I modded for ups dimensional support 1.2.6
here is my code for store/includes/classes/shopping_cart.php,
http://mithereal.pastebin.com/m7f14953b
If someone could look over it and submit ne corrections would be appreciated, just want someone that knows more to take a look at my code and see if i missed something.
Problem:
Here I have 3 vendors, 1- my default store ship method 2- my freight ship method and 3 my flat rate only shipping.
I can choose a product from either my store only, my freight method only or both store and freight and works great, however on ship method #3 gives the error
Redirect Loop
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
url in address bar:
/store/checkout_payment.php?osCsid=xxxxx
Here's a link to my checkout_shipping.php and.tpl
If someone could look over it and also submit ne corrections, I'm teaching myself php so any input would be very helpful |checkout_shipping.php|
http://mithereal.pastebin.com/mc86788a
|checkout_shipping.php.tpl|
http://mithereal.pastebin.com/m66a64f36

jack_strit
08-01-2008, 02:00 PM
Have you ever activated another shipping module before this? I remember having the same problem and I think it was related to that. If I remember, I fixed it by turning off ALL shipping mods getting a copy of the database via phpadmin installing the new DB (with a new name) and editing my config files accordingly. In other words, I don't know what I did...but it worked after that! I had another problem related to this to but i cannot remember exactly what the symptoms were. I had forgotten to put weights in all of my products, so I was getting errors. I will try to look at your code a little later today or tomorrow. I am a learner too, I like Larry Ullman's book PHP and MySQL for Dynamic Web Sites. Larry Ullman is a good teacher, but I also read PHP for Dummies before getting into his book.

J

mithereal
08-01-2008, 03:56 PM
well i figured it out, just a bug in packProducts function , fixed it by following the instructions in UPS XML Rates and Services v1.2.7 and 1.26 (http://www.oscommerce.com/community/contributions,1323) cleared all up, now the interesting thing is when i only select one item, should be going into a single 12X12X12 box but when i check out it displays United Parcel Service (XML) (3 pkg(s), 2.38 lbs total).
Under the product description i set it to 12x12x12 with 1lb as weight,
it duplicates the boxes on every item added to the cart, Causing the totals be wrong because of the incorrect box specs.

jack_strit
08-01-2008, 04:21 PM
Good! Glad you figured out part of it! The UPS XML thing...I don't know, I have not messed with the that mod yet, but I will need to pretty soon! I have found if I can get to the point of understanding the programmers intention, I can usually figure a problem out eventually.

J

silverping
11-02-2009, 11:05 AM
hi

i am getting this error when i click on some of the MVS links in admin:

Access Denied http://rippednutrition.com/admin/images/pixel_trans.gif No Right Permission Access Please contact your Web Administrator to request
more access or if you found any problem.

even after i ran the above supposed sql fix for it, this fix only fixed the error for some links, but not all of them.

any help would be greatly appreciated.

thanks

michael_s
11-02-2009, 12:12 PM
hi

i am getting this error when i click on some of the MVS links in admin:

Access Denied http://rippednutrition.com/admin/images/pixel_trans.gif No Right Permission Access Please contact your Web Administrator to request
more access or if you found any problem.



See the documentation:
http://wiki.oscdox.com/contributions

pgmarshall
11-02-2009, 12:53 PM
ie. You need to be able to enable any new admin modules into the File Access system which is installed in osCMax otherwise they will not show up in the menu. For instructions click here. (http://wiki.oscdox.com/files_access)