PDA

View Full Version : Mainpage.php ERROR_FILE_NOT_WRITEABLE



judoka
10-14-2003, 12:53 PM
Hi Everybody,
I had to put MS2 aside for a while due to time shortage, however I am now back and looking to finish my conversion to MS2. :D
I was just getting ready to print my welcome message on my main page but when I go to my define mainpage in the admin I get the following message,

ERROR_FILE_NOT_WRITEABLE

I have gone to my permissions setting and they seen to be setup correctly. Does any one know how I can fix this problem?

Thanks for any and all help.

judoka :D

Anonymous
10-14-2003, 02:09 PM
Is catalog/includes/languages/english/mainpage set at 777??

judoka
10-15-2003, 04:08 PM
No I keep trying to set it to 777 and it keeps defaulted back to 644???? I don't know why this is happening.

judoka

michael_s
10-15-2003, 04:44 PM
SSH to the server and chmod 777. Also, make sure you are the owner of the file... chown username:username

change 'username' to your user name.

Anonymous
10-16-2003, 07:22 AM
If you can't change the permissions, you may need to have your host do it for you.

judoka
10-16-2003, 08:11 AM
Hi Michael,
How's it going? I'm a little confuse with your reply first you wrote,



SSH to the server and chmod 777


What do you mean by "SSH"?

and second you wrote.



Also, make sure you are the owner of the file... chown username:username
change 'username' to your user name.


What do you mean by "chown"? I'm also confuse by "make sure you are the owner of the file" and "change 'username' to your user name". I didn't know that individual files had to be set to the proper username. I looked at the mainpage.php and there is no place to change the username. Can you please be a little bit more specify?

Thank you Michael,

judoka :D

michael_s
10-16-2003, 03:26 PM
That is Linux stuff. If you are not on linux, ignore it. If you are on linux, read a tutorial on CHMOD and CHOWN. They are file permission commands.

SSH is secure shell. Do a google search on ssh, chmod and chown... you will learn a lot!

judoka
10-16-2003, 04:30 PM
No, I am using WindowsXP pro. Any other ideas how I can fix the mainpage.php write problem? I don't understand why I can make permission changes on all other files, with no problems so far, but not the mainpage file.

michael_s
10-16-2003, 07:56 PM
In windows explorer, right click the file mainpage.php and in the context menu, select properties. Then, in the popup window, make sure 'read only' is not checked.

judoka
10-20-2003, 10:07 AM
Hi Michael,
I checked and the 'read only' box is not check. How ever I wanted to point out that I am working on the pre-install MS2 that you had added to my live site, on your server and not on my local machine. The one on my local machine is working fine. The one I am having the problem with is the live site one. I have upgraded it to the 1.5 upgrade release that you put out, and I also added a live support option, but other than that I havn't added anything else. I've even try uploading the mainpage.php file again just in case, but I still can't write to it.

michael_s
10-20-2003, 03:05 PM
judoka, if it related to aabox hosting account, you should always submit a help ticket!

I have fixed the issue, it was a file ownership problem. I did not realize this was an aabox account.