PDA

View Full Version : How to upgrade from OSC2.1 to OSC-MAX 1.5 ?



thetraveller
10-03-2003, 01:14 PM
Hi:

I have a store running the 2.1 MS and I want to upgrade it to the latest version OSC-MAX. How do I go about doing this?

Thanks

michael_s
10-03-2003, 01:57 PM
If you are experienced with MySQL / phpMyadmin and PHP, it is not that much trouble.

Use mysqldiff to compare the 2.1 database to the ms2-max database. This will give you the sql query to update your existing DB to match ms2-max. WARNING: Do not update your original 2.1 database. Make a copy of it, and do all the work on the copy. Run the query on the copy of your original database.

Then, install MS2-MAX in a separate directory from your original store, so it will not be touched. Then, after you install MS2-MAX and have it working, edit configure.php to point to your updated DB instead of the Standard MS2-MAX DB.

Finally, after it is all working nicely, you can start editing the templates and graphics to match your original site...

thetraveller
10-04-2003, 02:27 PM
Hi:

Thanks for the info however I am not completely comfortable with this proceedure.

Is this something that I could hire you to do for me? I can do the editing of the site once the DB has been updated.

Thanks,

Iain