PDA

View Full Version : admin install error



warrenthewindmill
09-27-2003, 01:02 AM
Can someone please have a look at this thread:

http://forums.oscommerce.com/index.php?showtopic=59354&hl=

I have been trying without success to install 1.5 for the last 3 days and cannot get my admin to work. I get this error:



Fatal error: Failed opening required 'includes/languages/english/FILENAME_LOGIN' (include_path='.') in /home/domains/my.com/user/htdocs/my_admin_name/login.php on line 58


Please help, I dumped a working version to install 1.5. i've tried reinstalling etc without success. What am I missing?

michael_s
09-27-2003, 12:24 PM
You should have installed it alongside your working site.

Something is missing from your installation. Some FTP programs will not overwrite files unless it is setup to do so. Check to see that you have filenames.php in both the admin/includes directory. That is where FILENAME_LOGIN is defined.

warrenthewindmill
09-28-2003, 04:22 AM
Thanks for the response.

I have filenames.php in both catalog/includes and admin/includes

If I hard code 'login.php' at line 58 of login.php I get the login panel successfully. If I enter 'default' and 'admin' as username and password the url shows as:



http://my_site.com/my_admin_folder/FILENAME_LOGIN?action=process


and the error:



Not Found
The requested URL /my_admin_folder/FILENAME_LOGIN was not found on this server.


What file is it looking for after the username and password have been entered? Obviously if I substitute login.php for FILENAME_LOGIN in the url it just redisplays the login panel again.

I going to try installing vanilla OScommerce to see if I get the same problem. Don't get me wrong I'm not giving up on Max but maybe it will take me closer to a solution.

Could an error in configure.php have caused this problem?

Any further ideas would be appreciated

Thanks again

warrenthewindmill
09-28-2003, 10:36 PM
Success possibly?

I did another complete reinstall and things are looking up. I can now get the login panel and get an error for wrong username/password. I read readme.txt of ADMIN ACCESS with LEVEL to discover username/password default set to admin@localhost.com and an alphanumeric which I changed in the db to admin (b4 I realised this was the default!)

Can't get in. How can I reset p/word so it works. Last time I just overwrote what was there with admin which presumably has screwed it up.

I should point out that I have yet to successfully log on because I used default/admin as per previous release of MS and when that didn't work I tried changing the password in the db before doing the sensible thing and reading the instructions for the admin contribution.

Hopefully I am nearly there but I've got to go to work now...

michael_s
09-28-2003, 10:55 PM
Open the ms2max sql file in the install dir, using a text editor, and find the admin data.

Empty the admin table in the databse using phpmyadmin. Copy the data from the sql file and then paste it into a query window in phpmyadmin and run it. That will restore the admin login to the default...

warrenthewindmill
09-29-2003, 09:28 AM
Many thanks for your help. I'll get started on the look and feel of the site, load up the products and away we go.