PDA

View Full Version : Products Attributes why wont this work right?



AHB900
09-30-2007, 10:18 PM
Hey guys im back again with a new question i have a bunch of products up right now and they require to input a size option. My problem is when i go to Products Attributes insert size and the options when i go to my item and click on size my sizes are NOT in order why does it do this? i mean my sizes are in order on my admin Products Attributes page but not on the actually item page. How come?

Thank you

Stephie
03-12-2008, 07:35 AM
changed this line in product_info.php;


$products_options = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . $products_options_name_values['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . $languages_id . "'");

to this;


$products_options = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . $products_options_name_values['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . $languages_id . "'". " order by pov.products_options_values_id");

All I added was;
. " order by pov.products_options_values_id"